Skip to:
Content

#2046 closed defect (duplicate)

JS Error: suggest has no method

Reported by: sc0ttkclark Owned by:
Milestone: 2.2.2 Priority: normal
Severity: blocker Version: 2.2.1
Component: Administration Keywords:
Cc: lol@…

Description

I’m getting this on all my sites that have upgraded to 2.2.x (tested on 2.2.1 too). It causes JS to fail, which then breaks every other page of the admin area that uses JS.

Uncaught TypeError: Object [object Object] has no method 'suggest'

This relates to this part of the code added to every page of the WP Admin area:

<script type="text/javascript">
			jQuery(document).ready(function() {

				var bbp_topic_id = jQuery( '#bbp_topic_id' );

				bbp_topic_id.suggest( ajaxurl + '?action=bbp_suggest_topic', {
					onSelect: function() {
						var value = this.value;
						bbp_topic_id.val( value.substr( 0, value.indexOf( ' ' ) ) );
					}
				} );
			});
		</script>

Change History (3)

comment:1 sc0ttkclark17 months ago

  • Cc lol@… added
  • Version changed from 2.1 to 2.1.2

I'm running WP 3.4.2 too

comment:2 sc0ttkclark17 months ago

  • Version changed from 2.1.2 to 2.2.1

comment:3 sc0ttkclark17 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1990

Note: See TracTickets for help on using tickets.