Skip to:
Content

bbPress.org

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1990 closed defect (fixed)

bbp_forum_id.suggest is not a function

Reported by: anointed Owned by:
Milestone: 2.2.2 Priority: normal
Severity: major Version: 2.2
Component: General - Administration Keywords:
Cc: lol@…

Description

Running bbPress 2.2nightly with WordPress 3.5beta2

When I publish a post and the screen returns to the edit post screen, I have the following error in Firebug

bbp_forum_id.suggest is not a function

The problem is that I am not able to change between the visual tab and the txt tab for editing posts. There are also other related js issues on the page.

I am running the default buddyPress theme on the site with the problem.

Here is more information on the problem:

TypeError: bbp_forum_id.suggest is not a function

Source:
wp-admin/post.php?post=291&action=edit&message=6

<script type="text/javascript">
jQuery(document).ready(function() {
var bbp_forum_id = jQuery( '#bbp_forum_id' );
bbp_forum_id.suggest( ajaxurl + '?action=bbp_suggest_forum', {
onSelect: function() {
var value = this.value;
bbp_forum_id.val( value.substr( 0, value.indexOf( ' ' ) ) );
}
} );
var bbp_topic_id = jQuery( '#bbp_topic_id' );
bbp_topic_id.suggest( ajaxurl + '?action=bbp_suggest_topic', {
onSelect: function() {
var value = this.value;
bbp_topic_id.val( value.substr( 0, value.indexOf( ' ' ) ) );
}
} );
});
</script> 

Change History (12)

#1 @alexvorn2
7 years ago

this is because the script with the function is used in the top of the source page, but the 'suggest' plugin is loaded in the footer.

#2 @alexvorn2
7 years ago

we should put the code in the bottom...

I think so.

#3 @anointed
7 years ago

so is this a bbPress issue, or a bbPress extra plugin issue?
I'd like to deactivate whatever is causing this if possible.

#4 @johnjamesjacoby
7 years ago

  • Milestone changed from Awaiting Review to Future Release

Not enough information to assess what's going on. You mention publishing "posts" but then reference the BuddyPress theme as the problem. Is this an issue with blog posts, creating topics and/or replies in wp-admin, etc?

For what it's worth, I'm not able to duplicate this on trunk with any default theme configuration. Sounds like something is off with a specific set of configurations. Including more detailed steps to reproduce would be helpful.

#5 @sc0ttkclark
7 years ago

  • Cc lol@… added
  • Component changed from General to Administration
  • Milestone changed from Future Release to 2.2.2
  • Severity changed from normal to major
  • Version changed from 2.1 to 2.2

Just upgraded to 2.2 and subsequently the 2.2.x latest on all my sites. Now I'm getting this on them, including http://podsframework.org/ admin areas. This JS is loaded on every admin page for me, which causes the JS error. Remaining JS on the page won't run since it errors out from this.

#6 @sc0ttkclark
7 years ago

Running 3.4.2 on the affected sites, and sorry, it's not on every admin page. It's on some dependency, I'm continuing to review to see what's causing it.

#7 @sc0ttkclark
7 years ago

Okay I'm lost in the PHP right now, I'll continue to look as I'm able to this weekend.

#8 @sc0ttkclark
7 years ago

Deployed a staging site version of the production of podsframework.org, disabled all plugins both network activated and site activated except for bbPress and Gravity Forms. I'm thinking Gravity Forms is hooking into some action or filter at some point, which triggers bbp_init / bbp_head actions and the following JS to output and error out.

#9 @sc0ttkclark
7 years ago

Turning no-conflict mode off on Gravity Forms resolves this (no-conflict mode removes all enqueues except ones that Gravity Forms does, to avoid issues with conflicting plugins/themes).

However, bbp_admin_head still gets triggered and the JS output on non-related admin pages outside of the bbPress admin.

#10 @sc0ttkclark
7 years ago

Yeah, I'm going to consider this one a confirmed bug on my side, but it only happens when the enqueued script isn't loaded -- the admin_head js/css should only be output on bbPress-related admin pages, not on every admin page across the whole dashboard. Should this be a separate ticket?

#11 @johnjamesjacoby
7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [4460]) Topic Suggest:

  • Only output topic suggest JS if on reply new/edit page.
  • Fixes #1990 (2.2 branch)

#12 @johnjamesjacoby
7 years ago

(In [4461]) Topic Suggest:

  • Only output topic suggest JS if on reply new/edit page.
  • Fixes #1990 (trunk)
Note: See TracTickets for help on using tickets.