Skip to:
Content

#1991 closed defect (fixed)

vBulletin importer replies show incorrect author

Reported by: anointed Owned by:
Milestone: 2.3 Priority: normal
Severity: critical Version: 2.2.3
Component: Importers Keywords: needs-testing
Cc: stephen@…

Description

I started getting a lot of people telling me that they were finding posts that were under different peoples names that belonged to them. This lead me to check the integrity of the importer, and sure enough, there are problems ALL OVER THE PLACE!

Here is what I do know, from just testing 1 reply, and I have hundreds of these.

On the vbulletin side (original import information for 1 post)

postid 315513
threadid 65570
username christythompson
userid 5783
dateline 1349317184
parentid 315511


userid 6534
username ayesha


user: christythompson
userid 5783

The above tells me that I have a post #315513 which is a reply belonging to thread id 315511.

The User who wrote this post is 5783 (christythompson)

*The Post shows user ayesha wrote this on the front-end*

On the WordPress import side:

user_login christythompson
ID 5078

user_login ayesha
ID 5783

user_login ayesha1
ID 5826
email imported_

***POSTS TABLE***
ID 309363
post_author 5783

What this is:
I searched for the same post as above in vbulletin. the Post ID in this case is 309363 and the post author is 5783
*Just like in vb*

The PROBLEM is that user 5783 in WordPress is not christythompson but is Ayesha.

Possible causes:
I noticed that I had some email addresses in my system that were as follows
imported_emailaddress@…

I had 440 of these imported_ addresses in my system.

When I check the vbulletin database there are 0 email addresses with imported_ in the url.

My best guess is that because WordPress does not like duplicate email addresses, that it is adding an imported_ in there, and is thus throwing off the user count?

Because the user christythompson user_id 5783 in vbulletin is user_login 5078 in WordPress, then there is no way that any of her posts can be correct.

I went through and checked about 100 of these user accounts now, and there is NO correlation that I can find as to how much the user_id numbers are off. I was hoping that all the users would be like -200, or +253 or something like that, but they are all different. I have seen differences ranging from 696 to 812 on the user_id from what it should be to what it is, and that was only with limited testing.

Bottom Line:
The importer does not work at all. While the data is input into the system, you cannot trust any of the user ids to match properly.

Heeeeelp :)

Attachments (1)

1991.diff (14.6 KB) - added by netweb 15 months ago.

Download all attachments as: .zip

Change History (15)

comment:1 anointed18 months ago

btw, I know there is already another thread on this, but the password portion is also broken. None of my users were able to login with their old credentials.

comment:2 anointed18 months ago

Digging really deep I figured out that every topic has the correct author however every single reply has the wrong author

this is telling me that the author id's don't have to be the same, but something is going wrong on the reply conversion not the author conversion.

I have run all the repair forums functions

comment:3 anointed18 months ago

I did a few more test runs today on a demo site and each time it imported the topic owners as the correct owners, but the owners of the replies was wrong on every occasion.

Does anyone feel like troubleshooting the problem with me?
I have a rather large vbulletin db for testing with that is readily available.

comment:4 johnjamesjacoby18 months ago

  • Milestone changed from Awaiting Review to 2.2
  • Summary changed from Importer imported topics and replies under wrong author to vBulletin importer replies show incorrect author

comment:5 johnjamesjacoby18 months ago

(In [4271]) vBulletin Converter:

  • Code formatting improvements.
  • Update meta keys for _bbp_user_id and _bbp_forum_id.
  • See #1991.

comment:6 johnjamesjacoby18 months ago

(In [4272]) vBulletin Converter:

  • Update inline docs
  • See #1991.

comment:7 netweb16 months ago

  • Cc stephen@… added
  • Keywords reporter-feedback added

@anointed,

Is this ticket still a valid?

via http://annointed.net/rebuilt-forums/

Last week I was notified by one of the forum moderators that the forum replies were actually broken with replies saying they belonged to the wrong usernames. I have just now finished updating the forums again and at the moment it looks like the new import worked.

comment:8 johnjamesjacoby16 months ago

  • Resolution set to fixed
  • Status changed from new to closed

Looks fixed, as his forums appear fully migrated now too.

Closing as fixed.

comment:9 netweb16 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

It appears this is still not working and I now have a vBulletin database to test with.

comment:10 netweb15 months ago

  • Keywords needs-testing added; reporter-feedback removed
  • Version changed from 2.1 to 2.2.3

1991.diff Cleaned whitespace and updated inline docs and phpdoc for consistency accross all import tools.

  • Added Forum topic count -> '_bbp_topic_count'
  • Added Forum reply count -> '_bbp_reply_count'
  • Added Topic reply count -> '_bbp_reply_count',
  • Added Topic date -> '_bbp_last_active_time'
  • Added Topic status open or closed
  • Fixed Reply title ->
  • Removed User Nice Name -> Not a valid vBulletin field
  • Added vBulletin user ICQ -> '_bbp_vbulletin_user_icq'
  • Added vBulletin user MSNM -> '_bbp_vbulletin_user_msn'
  • Added vBulletin user Skype -> '_bbp_vbulletin_user_skype'
  • Added function callback_topic_reply_count
  • Added function callback_topic_status
  • Added function callback_html (Strips vBulletin custom HTML first from $field before parsing $field to parser.php)
  • Added bbPress @mentions to converted vBulletin [quote] & [mention] BBCodes
  • Added preg_replace BBCode [video=youtube] to native bbPress WordPress embed

Known Issues: User must reset their password manually using /wp-login.php?action=lostpassword See #1969 for detailed password information.

Last edited 15 months ago by netweb (previous) (diff)

comment:12 netweb15 months ago

Updated 1991.diff added includes fixes in above comment and extra fixes below:

  • Fixed Topic Tags -> 'taxonomy'
  • Fixed Reply parent forum id -> '_bbp_forum_id'
  • Fixed Reply title -> 'post_title'
  • Added function callback_reply_title

(Password fix is not in here, will create a new ticket for that)

netweb15 months ago

comment:13 netweb15 months ago

The above 1991.diff can be committed to trunk.

I reopened #1969 vbulletin importer user pass does not work and updated with details of a potential fix.

comment:14 johnjamesjacoby15 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [4730]) Improvements to vBulletin importer. Props netweb. Fixes #1991.

Note: See TracTickets for help on using tickets.