Skip to:
Content

Opened 7 years ago

Closed 5 years ago

#1969 closed defect (worksforme)

vbulletin importer user pass does not work

Reported by: anointed Owned by: netweb
Milestone: 2.5 Priority: normal
Severity: normal Version: 2.2.3
Component: API - Importers Keywords:
Cc:

Description

Just imported by vbulletin 3x into bbPress and after testing about a dozen accounts that I know work in vbulletin, the passwords are not working in bbPress.

Not sure where to look at this point, but bottom line is the importer with vbulletin at least does not work for user passwords.

Change History (8)

#1 @anointed
7 years ago

@JJJ
if you want to go through this process to see what is happening, hit me up on skype as I will be trying to fix it. At the very least you will be able to see a live conversion and what is happening and not happening. I'll probably be on this one all night

I am able to see all the custom fields for the user-meta table for the user and indeed the old vb pass+salt is in the field and is the same as what vb had.

Last edited 7 years ago by anointed (previous) (diff)

#2 @johnjamesjacoby
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1886; looks like it's only the PW conversion that needs tweaking now.

#3 @netweb
6 years ago

  • Component changed from General to Importers
  • Milestone set to Awaiting Review
  • Resolution duplicate deleted
  • Status changed from closed to reopened
  • Version changed from 2.1 to 2.2.3

vBulletin passwords are still not working:

Potential Fix using source from the following plugin:

vB User Copy - Converts vBulletin users to WordPress users.

Using the above plugin to convert vBulletin users to WordPress users works perfectly and from my point of view in a very similar way to what we need to fix this issue and close this ticket.

From the source of the above plugin Lines 11 to 47 of vb_user_copy.php is what is needing to be tweaked and included in function authenticate_pass of vBulletin.php. The password hash algorithms work perfectly and it's just getting the right bits from that code for functions, arrays and output parsed.

The source also calls the WordPress core file /wp-includes/class-phpass.php

Passwords conversion works with all other bbPress importers and phpBb.php and Invision.php are notable examples where function authenticate_pass is using non WordPress compatible password hashes.

#4 @johnjamesjacoby
6 years ago

  • Milestone changed from Awaiting Review to 2.4

Moving this to 2.4. Not a regression, and will take some dedicated resources and testing to verify it's correct.

#5 @johnjamesjacoby
6 years ago

  • Milestone changed from 2.4 to 2.5

No time. Moving to 2.5.

#6 follow-up: @netweb
6 years ago

I have just spent the day playing with passwords :/

I will leave this ticket open for now, but unless extra feedback arrives before 2.5 is ready this ticket can be closed with resolution 'worksforme'.

#7 in reply to: ↑ 6 @johnjamesjacoby
6 years ago

  • Owner set to netweb
  • Status changed from reopened to new

Replying to netweb:

I have just spent the day playing with passwords :/

I will leave this ticket open for now, but unless extra feedback arrives before 2.5 is ready this ticket can be closed with resolution 'worksforme'.

Thanks for looking at this. I'm okay moving this into a later milestone or closing.

#8 @netweb
5 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Closing, worksforme

Note: See TracTickets for help on using tickets.