Skip to:
Content

bbPress.org

#3356 closed defect (bug) (duplicate)

_bbp_last_active_id not updating on new reply

Reported by: SirLouen Owned by:
Milestone: Priority: high
Severity: normal Version: trunk
Component: Component - Replies Keywords: has-patch
Cc:

Description

I've found that _bbp_last_active_id is not being updated on new reply.

I think this is the wrong behaviour because on the repair tool it picks the last reply
I've been checking includes/replies/functions.php function: bbp_update_reply_walker
And it only updates the freshness for 1 ancestor (the post, not the forum or the category, within the forum)

The problem is solved in the patch, just a conditional that is wrongly tested (checking if reply is pending, instead of checking that is not pending)

This is the first time I contribute with SVN so I'm not sure if this is the right way

Attachments (1)

patch-15-3-2020.diff (596 bytes) - added by SirLouen 21 months ago.
patch #3356

Download all attachments as: .zip

Change History (5)

#1 @SirLouen
21 months ago

#3297 was marked as a duplicate.

#2 @mike80222
12 months ago

This has been fixed, right?
It looks like it's on line 962 in the 2.6.6 release.

#3 @SirLouen
12 months ago

@mike80222 it's a little bit slow the bbpress review process, isn't it?

@johnjamesjacoby did not even take into consideration my patch, solving it in #3376 which is 20 posts further than this (and 79 away from #3297 where I also stated the patch)

I'm not sure which order reviewers follow to move forward in the bug solving process, but its surely time wasted for JJJ having to debug and solve this issue.

#4 @johnjamesjacoby
12 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3376.

Sorry, @SirLouen.

In this instance, I simply didn’t notice that issue was a duplicate of this one. You are correct that the first issue is the one that should have taken precedence. The way it went down was I saw the firehose notification in Slack for the latest one and happened to have a moment to work on it then. I didn’t think to check for dupes.

Thank you for the patch, and I apologize sincerely for missing it. 😞

Going to officially close this one as a dupe of that one. I know it’s backwards, but it’s the way it went down.

Thank you again, and sorry again. 🙏

Note: See TracTickets for help on using tickets.