Skip to:
Content

Opened 20 months ago

Last modified 20 months ago

#3151 new enhancement

Continue support for importing from phpBB 3.0 ?

Reported by: jrf Owned by:
Milestone: Future Release Priority: normal
Severity: normal Version: trunk
Component: API - Importers Keywords:
Cc: johnjamesjacoby, jrf

Description

By the looks of it, support for phpBB 3.0 was dropped in https://bbpress.trac.wordpress.org/ticket/2716

For the most part, the phpBB 3.1 script works for 3.0, except for some minor changes to the field mapping.
phpBB 3.0 support could be continued by adding an extra convertor which extends the phpBB class and which just overloads the setup_globals() method with the phpBB 3.0 mappings.

Unfortunately, the whole method would have to be overloaded as the field_map array does not use keys, so we can't selectively overload certain arrays keys or unset a few which are not needed.

If there is any support for this proposal, I'm happy to provide a patch.

Change History (3)

#1 @netweb
20 months ago

Thanks @jrf, I don't remember the specifics on why I decided *not* to do this when phpBB 3.1 was released.

We already have multiple importers for Kunena 1, 2, and 3 (Joomla), vBulletin 3 and 4, and I've a vB5 around somewhere but that's another story.

I've vague recollections of the phpBB schema change relating to profiles data that shipped in 3.1 had been added and was being used in the wild on phpBB 3.0 installs so there was no specific release version that could be used as a "hard" cutover to differentiate and use as an identifier as to what version of the converter to use for what version of phpBB was being imported.

That then coupled with the ease of upgrading a phpBB database to the latest scheme is well documented and pretty quick and easy to do I went with the recommendation that users should update the phpBB database they have to the latest phpBB before importing.

#2 @netweb
20 months ago

  • Milestone changed from Awaiting Review to Future Release

p.s A patch for this would be to use revision 5795 of the phpBB.php file and rename it as phpBB30.php and the current phpBB.php to phpBB31.php

https://bbpress.trac.wordpress.org/browser/trunk/src/includes/admin/converters/phpBB.php?rev=5795

I'll dig around and try to dig up some of my notes and the test databases I've got locally for 3.0 and 3.1

Going to move this into the "Future Release" milestone for now, to keep "Awaiting Review" as clear as possible

#3 @jrf
20 months ago

@netweb Thanks for the info. I've already got a convertor setup now for phpBB 3.0 based off the current trunk. I just went through the history of the file to get the right setup. Test import is currently still running.
As I said in the original issue, I'd be happy to send it in as a patch.

Note: See TracTickets for help on using tickets.