Skip to:
Content

bbPress.org

Opened 7 years ago

Closed 6 years ago

#2473 closed enhancement (duplicate)

Pending Post viewable only to the user who posted it

Reported by: mariz_p Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.4.1
Component: Component - Topics Keywords:
Cc:

Description

I want to view the pending post to the user who posted it not to everyone. It will be awkward seeing awaiting for moderation.
I have tried modifying the plugin bbpress moderation but still no luck and when I tried to add it on bbpress core an error came up or just posting all the topics. I am hoping for your kind response for this.

I really need help for my site. Thanks.

Attachments (1)

bbPressUserPendingTopicsReplies.png (65.4 KB) - added by netweb 7 years ago.

Download all attachments as: .zip

Change History (8)

#1 @netweb
7 years ago

"Include the ability for users to see all of their own topics & replies on their profile page regardless of the topic/reply post status."

Similar to eg http://example.com/forums/users/admin/topics/?view=all
(Side Note: Current ?view=all does not include post status 'pending')


Originally via this bbpress.org discussion.

#2 @netweb
7 years ago

  • Milestone changed from 2.4.2 to Awaiting Review
  • Priority changed from highest to normal
  • Type changed from task to enhancement
  • Version changed from 2.1 to 2.4.1

#3 @johnjamesjacoby
7 years ago

  • Component changed from General to Topics
  • Milestone changed from Awaiting Review to 2.6

We could add pending to the array of statuses. Let's look at this after 2.5 ships.

(Edit: seriously, autocorrect?

Last edited 7 years ago by johnjamesjacoby (previous) (diff)

#4 @johnjamesjacoby
7 years ago

  • Milestone changed from 2.6 to 2.7

Bump to 2.7.

#5 @netweb
7 years ago

Related: #2341

#6 @johnjamesjacoby
7 years ago

  • Milestone changed from 2.7 to 2.8

Bumping all 2.7 to 2.8 milestone.

#7 @netweb
6 years ago

  • Milestone 2.8 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Marking this as a duplicate of #2645, this is now in /trunk and will ship as part of bbPress 2.6

Note: See TracTickets for help on using tickets.