Skip to:
Content

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#2397 closed defect (duplicate)

Threaded replies bugged for 1 topic (weirdest bug i ever seen)

Reported by: unsalkorkmaz Owned by: jmdodd
Milestone: Priority: high
Severity: critical Version: 2.4
Component: Component - Replies Keywords:
Cc: unsalkorkmaz@…, shane@…

Description

Topic is live in
http://theme.firmasite.com/support/topic/boostrap-3-0-menu-on-iphone/

For example #701 post is normally replied to #post-696 as you can see in this screenshot:
http://i.imgur.com/HoYUWXR.png

But its not showing as threaded. There is 4-5 threaded reply in that topic and somehow all of them bugged. But its only that topic. Other topics are working normally. I am not sure what trigger the bug. I am adding an attachement of that topic's database. I tried to import to it in another wordpress install and another wordpress theme but its still bugged so its something about that topic.

(Sorry for shit explanation, tried my best)

Attachments (1)

firmasitetheme.wordpress.2013-08-25.xml (122.1 KB) - added by unsalkorkmaz 6 years ago.

Download all attachments as: .zip

Change History (26)

#1 @johnjamesjacoby
6 years ago

  • Keywords reporter-feedback added

Can you be more specific about what the actual problem is? I don't know what you mean by 'bugged.'

#2 @unsalkorkmaz
6 years ago

  • Cc unsalkorkmaz@… added

Here is a threaded topic example in same site:
http://theme.firmasite.com/support/topic/menu-not-working-well-on-mobile-menu-items-dont-appear/
So normally threaded reply system is working but its somehow bugged in that topic. How is it bugged? i dont know. What type of details you need, i can provide. You can actually import my attached topic backup to your local installation to try to see it.

Last edited 6 years ago by unsalkorkmaz (previous) (diff)

#3 @unsalkorkmaz
6 years ago

Another bug maybe related to this:
http://theme.firmasite.com/support/topic/errors-with-version-1-2-4/
In this topic, 2nd showing reply (#745) is actually 3th one.

If i revert bbpress plugin back to 2.3.2 version, it shows in correct order but in 2.4, it shows in wrong order.

Last edited 6 years ago by unsalkorkmaz (previous) (diff)

#4 follow-up: @netweb
6 years ago

@unsalkorkmaz A detailed explanation of what 'is happening' compared to what is 'expected' is much more helpful than you think it is 'bugged'.

Looking at the XML dump you attached to this ticket of the topic examining the _bbp_reply_to values from wp_postmeta for this topic here.

The structure should be displayed similar to this:

  • Topic (ID=684)
  • Reply (ID=685) - _bbp_reply_to = 685
    • Reply (ID=686) - _bbp_reply_to = 685
      • Reply (ID=687) - _bbp_reply_to = 686
        • Reply (ID=690) - _bbp_reply_to = 687
          • Reply (ID=691) - _bbp_reply_to = 690
            • Reply (ID=692) - _bbp_reply_to = 691
            • Reply (ID=700) - _bbp_reply_to = 694
        • Reply (ID=693) - _bbp_reply_to = 687
          • Reply (ID=694) - _bbp_reply_to = 693

The structure is displayed as:

  • Topic (ID=684)
  • Reply (ID=685)
  • Reply (ID=686)
  • Reply (ID=687)
  • Reply (ID=690)
  • Reply (ID=693)
  • Reply (ID=691)
  • Reply (ID=692)
  • Reply (ID=696) - _bbp_reply_to = 691
  • Reply (ID=694)
  • Reply (ID=700)
  • Reply (ID=701) - _bbp_reply_to = 696
  • Reply (ID=712) - _bbp_reply_to = 700

It appears that you have 'reply threading' enabled as the topic here works as expected.

As to why this is happening I do not know, all the wp_posts & wp_postmeta values look fine to me.

EDIT: Updated 6th June 2014 - Added the _bbp_reply_to values

Last edited 5 years ago by netweb (previous) (diff)

#5 @unsalkorkmaz
6 years ago

Thanks @netweb for better explanation :)
Sorry for your unnecessary time lost because of me.

I think it has to be related with problem i described in comment:3 because there is no reason that 3th reply is showing in 2nd place

Last edited 6 years ago by unsalkorkmaz (previous) (diff)

#6 @johnjamesjacoby
6 years ago

  • Keywords needs-testing added
  • Milestone changed from Awaiting Review to 2.4.1
  • Priority changed from normal to high

#7 @unsalkorkmaz
6 years ago

I disabed threaded replies. Something clearly bugging it and it seems i am alone in this problem.. interesting

#8 @netweb
6 years ago

I have no new thoughts on this except to ask if you still see this issue when using the Twenty Ten/Eleven/Twelve/Thirteen themes on the same bbPress install?

#9 @unsalkorkmaz
6 years ago

I tested that in other themes if i remember correct. Because i am theme writer and if it was a theme bug, i had to fix it.

Basically i attached the file. Just create a clean bbpress install, enable threaded replies, import content and checkyourself in whatever theme. It stills orders wrong.

#10 @netweb
6 years ago

I still don't have an answer to why this is happening 100% reproducible with your attached .xml file, other than that though I cannot reproduce the issue in other way.

Thinking aloud for a moment, it might be worth investigating if this has something to do with wp-importer rather than bbPress.

@unsalkorkmaz Did you only discover this issue after importing to your bbPress install?

Did you create the .xml file attached specifically to attach to this ticket so we could reproduce the issue?

How did you edit the attached .xml file so it only contained that specific topic in the export instead of all your forums, topics, replies, posts, pages?

#11 @unsalkorkmaz
6 years ago

@netweb there were no topic import or something in original website. http://theme.firmasite.com/support/topic/boostrap-3-0-menu-on-iphone/

I can open threaded reply support again if you want. Its just stays in there. Time zone is different then normal wordpress (UTC+3), maybe it triggers something. I dont know.. Its certain that its a rare bug but when its triggered in a website, it happens lots of time in same website. It should be about a setting that is triggering it.

#12 @johnjamesjacoby
6 years ago

  • Milestone changed from 2.4.1 to 2.4.2
  • Version changed from trunk to 2.4

Punting to 2.4.2 to get 2.4.1 out the door.

#13 @netweb
6 years ago

Whilst looking for something unrelated I came across this ticket:

#WP8841: "Threaded comments display out of order if conditions are met."

Be worth debugging some various 'max_depth' settings I think.

Last edited 6 years ago by johnjamesjacoby (previous) (diff)

#14 @johnjamesjacoby
6 years ago

  • Owner set to jmdodd

#15 @johnjamesjacoby
6 years ago

  • Milestone changed from 2.4.2 to 2.6

#16 @netweb
5 years ago

Related: This topic and this topic on bbpress.org.

#17 @artkahlich
5 years ago

Last night I took a look at and managed to correct the 2 topic threads where threading was not working. In these 2 threads, I went into the administrator dashboard, then to "All Replies". I looked at each reply to the thread in the edit screen. What I found were 2 different symptoms causing the failures.

In one case, a reply (say #306) that was being replied to did not have a permalink ending in "/reply/306/" - instead it had a permalink the same as the topic. When I updated the permalink to end with the reply number, went back to the thread and refreshed the browser, threading indents were working.

In the other case, a reply (say #396) had the correct permalink, but in the "Reply Attributes" its "Reply To" attribute was also 396 - it somehow was a reply to itself. When I corrected that, went back to the thread and refreshed the browser, threading indents were working.

There were also some places where it was obvious that moderators and contributors were doing replies to each other's replies with no threading, but here the permalinks were correct and the "Reply To" attribute was 0, so I am going to say for now that they did not use the REPLY link on the comment they were replying to, but did a reply to topic instead.

#18 @netweb
5 years ago

@artkahlich Thanks for that info.

#19 follow-up: @artkahlich
5 years ago

Here is another from one of my moderators operating off of a RSS feed from our forum:

If I click on the link in the RSS message, it sends me to the forum "http://ootbcomp.com/topic/metadata/#post-478". If I then hit reply in that message I am still at that URL, and the reply doesn't indent.

However, if I come in from the front and navigate to that forum so my URL is "http://ootbcomp.com/topic/metadata/", manually find # 478 and click the reply button then my URL changes to "http://ootbcomp.com/topic/metadata/?bbp_reply_to=478&_wpnonce=b0c76ed955#new-post" and the reply indents properly.

#20 @artkahlich
5 years ago

Regarding my previous posting from one of my moderators:

I have tried repeatedly and failed to duplicate what he reported. Either something in the database changed, or he did not recognize the difference between the "REPLY" link and the "#478" link just to the right of it on the message toolbar.

Last edited 5 years ago by artkahlich (previous) (diff)

#21 in reply to: ↑ 19 @netweb
5 years ago

Replying to artkahlich:

If I click on the link in the RSS message, it sends me to the forum "http://ootbcomp.com/topic/metadata/#post-478".

Correct RSS feeds and subscription email reply links use bbp_reply_url() which is the 'permalink' of the post.

If I then hit reply in that message I am still at that URL, and the reply doesn't indent.

This works for me and the reply is indented (i.e. a reply-to)

or he did not recognize the difference between the "REPLY" link and the "#478"

This seems the most likely.

#22 @shanebp
5 years ago

  • Cc shane@… added

#23 @johnjamesjacoby
5 years ago

  • Milestone changed from 2.6 to Future Release

I've gone through each scenario where replies can be created, and then later edited:

  • topic splits
  • reply moves
  • edit theme-side
  • edit admin-side
  • trash/untrash
  • spam/unspam

I'm not able to find a case where the _bbp_reply_to gets mismatched. I think there's value in revisiting this once we have some unit tests going. Moving this into the Future Release milestone until then.

#24 in reply to: ↑ 4 @netweb
5 years ago

  • Keywords reporter-feedback needs-testing removed
  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Replying to netweb:

The structure should be displayed similar to this:

  • Topic (ID=684)
  • Reply (ID=685) - _bbp_reply_to = 685
    • Reply (ID=686) - _bbp_reply_to = 685
      • Reply (ID=687) - _bbp_reply_to = 686
        • Reply (ID=690) - _bbp_reply_to = 687

...

I just checked the _bbp_reply_to values of this data, Reply ID 685 should not have a _bbp_reply_to value or if there is a value in wp_postmeta it should be 0
This can be tested by importing the attached WordPress WXR XML file:

  • With threaded replies enabled the topics replies are 'flat' - Result: Unexpected
  • Update in wp_postmeta post ID 685 _bbp_reply_to from 685 to 0 Result: Expected

I'm going to close this as a duplicate in favour of #2588 as it has a patch.

#25 @netweb
5 years ago

Repair tool also in #2588 to repair any occurrences of _bbp_reply_to in wp_postmeta where post_id = meta_value

Note: See TracTickets for help on using tickets.