Skip to:
Content

bbPress.org

Opened 8 years ago

Closed 8 years ago

#2398 closed defect (duplicate)

Dropdown boxes not working as expected on settings page

Reported by: alexvorn2 Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.1
Component: General Keywords: needs-patch
Cc:

Description

Me using Firefox 23.0.1
OS - Windows 7 64b

To replicate:
go to settings page of the wp-admin/options-general.php?page=bbpress and try to open a select box

What happens:
The dropdown boxes closes ofter the click.

What should happen:
The dropbox should show after the click.

Cause:
Select tag <select> is inside <label> tag that has a value names for,
so, clicking the dropdown box simulates clicking the checkbox and the dropdown box too.

For what is for value:
"A label that is associated with a control via for will be clickable. Clicking it selects the control. Highly useful with radio/checkboxes in particular. It also has accessibility implications for screen readers for the visually impaired."

Change History (1)

#1 @netweb
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closing, Duplicate of #2392

Note: See TracTickets for help on using tickets.