Skip to:
Content

bbPress.org

Opened 8 years ago

Closed 8 years ago

#2339 closed defect (fixed)

BuddyPress: Saving a group's settings wipes out forum tab

Reported by: r-a-y Owned by: johnjamesjacoby
Milestone: 2.4 Priority: normal
Severity: normal Version: 2.2
Component: Extend - BuddyPress Keywords: has-patch
Cc:

Description

If you have a bbPress forum enabled in a BuddyPress group and attempt to save the BP group's admin settings, the forum tab will be removed.

Steps to reproduce:

  1. Make sure you have a BP group with forums enabled
  2. Navigate to the group's "Admin > Settings" page and click "Save".
  3. The group's "Forums" tab is now removed

This is due to BP explicitly looking for a 'group-show-forum' POST value in the group admin settings page:
https://buddypress.trac.wordpress.org/browser/tags/1.7.2/bp-groups/bp-groups-screens.php#L556

Because this value does not exist, the forum tab will be removed.

The easiest way to fix this is to add a hidden input 'group-show-forum' field on the group settings page.

Attachments (1)

2339.01.patch (1.4 KB) - added by r-a-y 8 years ago.

Download all attachments as: .zip

Change History (3)

@r-a-y
8 years ago

#1 @johnjamesjacoby
8 years ago

  • Milestone changed from Awaiting Review to 2.4

#2 @johnjamesjacoby
8 years ago

  • Owner set to johnjamesjacoby
  • Resolution set to fixed
  • Status changed from new to closed

In 5027:

Introduce group_settings_hidden_field() method to prevent the settings page from accidentally disabling the group forum. Props r-a-y. Fixes #2339.

Note: See TracTickets for help on using tickets.