Skip to:
Content

bbPress.org

Opened 8 years ago

Closed 8 years ago

Last modified 5 years ago

#2340 closed enhancement (fixed)

Hierarchical replies enahancments

Reported by: alex-ye Owned by:
Milestone: 2.4 Priority: normal
Severity: normal Version: trunk
Component: Component - Replies Keywords: needs-patch
Cc: jmdodd@…

Description

Hi, First day of testing the new bbPress feature "Hierarchical replies" for now I have some notes:

1- If I am not miss something, I can't see any sufferance between the 0 and 1 in the deep level setting.

2- I can't set the reply-to input to 0, seems something wring with bbp_update_reply_to() function.

3- I can't see any reason to show the reply-to link in the deepest replies ( I can't get the correct meaning in English :D )

4- The reply-to from title should be changed depending on the reply ID ( Reply To: %topic-title% - Reply %reply-id% )

that's all for now...

Change History (17)

#1 @jmdodd
8 years ago

  • Cc jmdodd@… added

#2 follow-up: @alex-ye
8 years ago

another bug need someone to confirm: the _bbp_replies_per_page option doesn't work in the topics anymore.

Last edited 8 years ago by alex-ye (previous) (diff)

#3 @alex-ye
8 years ago

bug: the reply-to link shouldn't be shown in the archive pages like the user-replies, right?

#4 @alex-ye
8 years ago

Please can you check the child replies CSS classes, The Odd/Even classes and could you mind adding 'bbp-parent-reply-%" class?

#5 @johnjamesjacoby
8 years ago

  • Milestone changed from Awaiting Review to 2.4

#6 @johnjamesjacoby
8 years ago

In 4961:

Allow registering of settings that don't need callbacks or titles. See #2340.

#7 @johnjamesjacoby
8 years ago

In 4962:

When adding the reply_to link, only add onclick if threaded replies are enabled. See #2340.

#8 @johnjamesjacoby
8 years ago

In 4963:

Tweak threaded reply setting to more closely match threaded comments, and add the default settings to the options array. Fixes issue with 0/1 level deep not matching intended behavior. See #2340.

#9 in reply to: ↑ 2 ; follow-up: @johnjamesjacoby
8 years ago

Replying to alex-ye:

another bug need someone to confirm: the _bbp_replies_per_page option doesn't work in the topics anymore.

We've turned off topic pagination for threaded replies for now. We'll likely iterate on this more in future versions.

#10 in reply to: ↑ 9 ; follow-up: @alex-ye
8 years ago

Replying to johnjamesjacoby:

Replying to alex-ye:

another bug need someone to confirm: the _bbp_replies_per_page option doesn't work in the topics anymore.

We've turned off topic pagination for threaded replies for now. We'll likely iterate on this more in future versions.

Hmmm, sad news :(

The topic pagination is the most thing I use in my forums, How you sugget me to deal with a topic has more than 100 reply?

Topic replies are diffrent from post comments...

At least can you explain why the pagination will doesn't work?

#11 @johnjamesjacoby
8 years ago

In 4964:

In bbp_update_reply_to(), allow $reply_to to be 0 and delete if it's being set to empty. See #2340.

#12 @johnjamesjacoby
8 years ago

In 4965:

In bbp_update_reply_to(), allow $reply_to to be 0 and delete if it's being set to empty. See #2340.

#13 @johnjamesjacoby
8 years ago

In 4966:

Add topic reply link template functions. See #2340.

#14 in reply to: ↑ 10 ; follow-up: @johnjamesjacoby
8 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Replying to alex-ye:

At least can you explain why the pagination will doesn't work?

We haven't decided on which approach is best to take:

  • Paginate based on root thread count
  • Paginate based on total visible replies
  • Some new hybrid approach

We're basically mirroring the P2 theme, in the sense that if you're asking for a visible hierarchy, you probably want as much of the conversation available as possible, without the concerns of splicing hierarchical replies mid-conversation.

I'm of the opinion that we either need to count the root-replies, and paginate by those, or dream up some new approach. 20 visible replies in a hierarchy isn't enough, and it poses the problem of what to do if the number of visible replies cuts off conversations.

Since this is a new feature, I want to see how our users react before putting false limitations on it.

Marking this ticket as resolved, since the issues raised in it are fixed. For more bugs or issues pertaining to threaded replies, please open single tickets for each issue.

Thanks for keeping an eye on this!

#15 @johnjamesjacoby
8 years ago

In 4973:

Add bbp_is_single_topic() check to topic pagination count, before using threaded count output. Fixes issue where threaded output would incorrectly appear on user profile replies. See #2340.

#16 in reply to: ↑ 14 @alex-ye
8 years ago

Replying to johnjamesjacoby:

We haven't decided on which approach is best to take

I see now :), It is really confuse point to discuss!
Can you open ticket for this, so the users know it's a known bug?

Since this is a new feature, I want to see how our users react before putting false limitations on it.

I agree with you, but I would love to see this bug resolved in the final version since the both are important features.

Thanks you for everything :)

Note: See TracTickets for help on using tickets.