Skip to:
Content

bbPress.org

Opened 8 years ago

Closed 7 years ago

#2198 closed enhancement (wontfix)

reply to box cut off

Reported by: intimez Owned by:
Milestone: Priority: normal
Severity: normal Version: trunk
Component: General - Content Creation Keywords:
Cc: mercijavier@…

Description

since the box gets cut off on the right side in responsive mobile view, users can no longer switch to visual/text mode nor can they insert/unlink and insert picture since the buttons are not in view. post content above the reply-to box fit correctly.

http://i.imgur.com/8ZUJY45.png

twenty twelve 1.1
wordpress 3.5.1
buddypress trunk-6776
bbpress trunk-4761

Change History (5)

#1 @alexvorn2
8 years ago

it can't be resized so much, the only solution is to use a text area instead.

This editor is part of wp_editor component that is designed for back-end and not for mobile view, it has a minimun width that help buttons to be only in a line...

I don't see a problem because most of mobile phones have great resolutions, that makes everything fit on the screen, so support for 320X240 pixels is not a good idea.

#2 @intimez
8 years ago

Trying to fit everything on the screen can be a mess. I may be wrong but I believe the lowest common would be 320x480 (iphone?) so it should at least support that size and go from there.

#3 @johnjamesjacoby
8 years ago

  • Component changed from Forums to Content Creation
  • Milestone Awaiting Review deleted
  • Priority changed from high to normal
  • Resolution set to wontfix
  • Severity changed from major to normal
  • Status changed from new to closed
  • Type changed from defect to enhancement

Would need a fix either with CSS, or in WordPress core to make the editor responsive. I'm inclined to wait for the latter, so that we don't need to support a temporary kludge.

Even though the issue is valid'ish, I'm closing it as wontfix. If someone comes up with a creative patch that's not very complex, go ahead and reopen with a patch.

#4 @mercime
7 years ago

  • Cc mercijavier@… added
  • Resolution wontfix deleted
  • Status changed from closed to reopened

Editor width addressed in CSS at patch https://bbpress.trac.wordpress.org/ticket/1933 down to 240 resolution. In some smartphones, only the text editor shows up by default.

#5 @netweb
7 years ago

  • Resolution set to wontfix
  • Status changed from reopened to closed

Closing again, everything looks good now via #1933 patch

Note: See TracTickets for help on using tickets.