Skip to:
Content

bbPress.org

Opened 9 years ago

Closed 9 years ago

#2157 closed defect (bug) (fixed)

Add tool for repairing the relationship of forums sticky posts topics to the actual parent

Reported by: gawain Owned by:
Milestone: 2.3 Priority: normal
Severity: normal Version: trunk
Component: Component - Topics Keywords: has-patch
Cc: stephen@…

Description

I've repeatedly run into the situation where for whatever reason the a forums _bbp_sticky_topics meta gets out of sync with the topic's parent.

This patch adds a repair function to fix this after the fact. Does not address root cause.

I'm not sure of the SOP with changing the indexing of the bbp_admin_repair_list() array, so I just slotted it in an unused index number.

Attachments (1)

bbpress-admin-tools-sticky.patch (3.2 KB) - added by gawain 9 years ago.

Download all attachments as: .zip

Change History (5)

#1 @alexvorn2
9 years ago

  • Component changed from General to Topics
  • Keywords needs-testing added

#2 @netweb
9 years ago

  • Cc stephen@… added

Related: #2126

#3 @johnjamesjacoby
9 years ago

  • Keywords needs-testing removed
  • Milestone changed from Awaiting Review to 2.3

#4 @johnjamesjacoby
9 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [4695]) Introduce tool for repairing each forum's sticky topic ID's. Props gawain. Fixes #2157.

Note: See TracTickets for help on using tickets.