Skip to:
Content

Opened 18 months ago

Closed 18 months ago

Last modified 18 months ago

#2021 closed defect (fixed)

bbPress breaks MCE Toolbar on WP Posts & Pages with Jetpack?

Reported by: netweb Owned by:
Milestone: 2.2 Priority: normal
Severity: normal Version: 2.1
Component: Front-end Keywords:
Cc:

Description

This is based on the following bbpress.org thread:

http://bbpress.org/forums/topic/bbpress-install-breaks-wp-editor/

Snip from @IanSymonds here

When I activate bbPress, the editor on my currently existing pages and posts does not work.

Symptoms:

The “kitchen sink” toolbar is no longer displayed.
The text in the editor panel (“Visual” tab) is white HTML on a white background.
When adding a new page or post, the toolbar appears ok
When adding a new forum or topic in bbpress, the toolbar appears ok
If I deactivate bbPress, I can edit existing pages/posts with the editor working correctly.

This is a brand-new wordpress 3.4.2 installation bbpress 2.1.2 just installed.

No other plugins or themes are yet installed.

and further on by @zeaks here

Using Twenty Tweleve wordpress theme, the default compat theme the html and visual tabs are to the left and if clicked they create and tags, there’s no background behind the toolbar. If I click the link button, the popup shows up but it looks as if all the CSS for it is missing and I see constant loading icons. If I disable the “fancy” toolbar, I don’t see a toolbar or buttons at all. If I switch to Twenty Ten forum theme, then the toolbar shows.

Update, looks like a conflict with Jetpack, works fine if I disable it. I was using Version 2.1.3 already :/

I am currently 'mobile' and cant setup WP 3.4.2 with bbP 2.1.3 and Jetpack 2.0 to repro this but will investigate further once home.

Change History (3)

comment:1 NickMackz18 months ago

I have the same problem on my site. I did a bit of experimenting and discovered that it works correctly if I use Twenty Ten, but not if I use the default BuddPress theme or Custom Community. It works fine on the BuddyPress and Custom Community themes if Jetpack is disabled.

The editor in wp-admin works ok, only the editor for topics and replies on the forums has the problem.

comment:2 johnjamesjacoby18 months ago

  • Milestone changed from Awaiting Review to 2.2
  • Resolution set to fixed
  • Status changed from new to closed

Addressed this as much as I could in bbPress 2.1.3. Jetpack 2.0.1 will come with a fix for this, as well as a possible fix in WordPress core.

Closing this as resolved, since it's not directly a bbPress issue, and it's already fixed in Jetpack.

Note: See TracTickets for help on using tickets.