Skip to:
Content

#2902 closed task (fixed)

Bump minimum required WordPress version from 3.6 to 4.0

Reported by: netweb Owned by: netweb
Milestone: 2.6 Priority: normal
Severity: normal Version:
Component: General Keywords:
Cc:

Description

Via https://wordpress.org/about/stats/, usage stats for old versions look like this (release dates in parentheses):

  • 3.6: 1.6% (2013-08-01)
  • 3.7: 1.1% (2013-10-13)
  • 3.8: 3.5% (2013-12-12)
  • 3.9: 4.9% (2014-04-16)
  • 4.0: 5.3% (2014-09-04)

Quoting, paraphrasing and revising Boone via https://buddypress.trac.wordpress.org/ticket/6258#comment:9:

I think a good guideline for "most recently stable" is that we should maintain support for WordPress versions going back at least 12 months, which would suggest that we should definitely keep support for at least 4.0.x.

  • 3.6 was released ~ 29 months ago and is now less than 5%
  • 3.7 was released ~ 27 months ago and is now less than 5%
  • 3.8 was released ~ 24 months ago and is now less than 5%
  • 3.9 was released ~ 20 months ago and is now less than 5%

The 5% rule suggests that we drop official support for 3.6, 3.7, 3.8, and 3.9.

Further to the above stats are some more stats via w.org relating to bbPress 2.5.x and WordPress 3.x/4.x usage:

  • 3.3 - August 2015 0.0% - January 2016 0.0%
  • 3.4 - August 2015 0.0% - January 2016 0.0%
  • 3.5 - August 2015 0.2% - January 2016 0.0%
  • 3.6 - August 2015 0.3% - January 2016 x.x%
  • 3.7 - August 2015 0.5% - January 2016 x.x%
  • 3.8 - August 2015 3.7% - January 2016 x.x%
  • 3.9 - August 2015 6.7% - January 2016 x.x%
  • 4.0 - August 2015 9.1% - January 2016 x.x%
  • 4.1 - August 2015 16.0% - January 2016 x.x%
  • 4.2 - August 2015 51.6% - January 2016 x.x%
  • 4.3 - August 2015 11.8% - January 2016 x.x%
  • 4.4 - August 2015 0.0% (~20 sites) - January 2016 x.x%

Based on the above, I'm going to suggest we bump the minimum official supported version to 4.0. If everyone else is OK with this, I suggest we do the following:

  1. Bump the minimum supported version in trunk
  1. Open a separate ticket where someone does a quick review of backward compatibility and progressive enhancements in bbPress that become obsolete when we no longer support 3.6, 3.7, 3.8, and 3.9, and make some recommendations for removal (or leaving stuff alone, as appropriate)
  1. Post about this on bbpdevel.wordpress.com
  1. Formalize these steps for future release cycles

Related:

Note: Updated January 2016 stats will be provided and updated shortly

Change History (2)

#2 @netweb
19 months ago

  • Owner set to netweb
  • Resolution set to fixed
  • Status changed from new to closed

In 5991:

Bump minimum WordPress requirement to 4.0.

Fixes #2902.

Note: See TracTickets for help on using tickets.