Skip to:
Content

bbPress.org

Opened 4 years ago

Closed 4 years ago

#2868 closed enhancement (fixed)

Theme Compat: Add singular.php to list of wrapper template files for bbPress content

Reported by: mercime Owned by: netweb
Milestone: 2.6 Priority: normal
Severity: normal Version:
Component: Appearance - Theme Compatibility Keywords: has-patch commit
Cc: mercijavier@…

Description

bbPress pages no longer have any h1 level headings when Twenty Sixteen is activated. This is because the forums/topics are now wrapped in the theme's index.php which has h2 level heading for content. The page.php file that we're counting on is not available in the theme because Twenty Sixteen uses singular.php (introduced in WP#22314) in lieu of page.php and single.php.

Attached patch adds singular.php to the list of wrappers.

Attachments (1)

2868.patch (642 bytes) - added by mercime 4 years ago.

Download all attachments as: .zip

Change History (6)

@mercime
4 years ago

#1 @mercime
4 years ago

  • Cc mercijavier@… added
  • Keywords has-patch added

#2 @thebrandonallen
4 years ago

  • Keywords commit added

Confirmed. Thanks @mercime!

#3 @thebrandonallen
4 years ago

  • Milestone changed from Awaiting Review to 2.6

#5 @netweb
4 years ago

  • Owner set to netweb
  • Resolution set to fixed
  • Status changed from new to closed

In 5950:

Theme Compatibility: Add support for singular.php in the root template hierarchy.

This changeset adds upport for the singular.php fallback template introduced in [WP22314]

Props mercime
Fixes #2868

Note: See TracTickets for help on using tickets.