Skip to:
Content

Opened 14 months ago

Closed 14 months ago

Last modified 12 months ago

#2207 closed defect (invalid)

Topics and replies no longer visible in front end (bbPress 2.3 beta 2)

Reported by: kraigg Owned by:
Milestone: Priority: normal
Severity: normal Version: trunk
Component: Moderation Keywords:
Cc: stephen@…

Description

Topics and replies are no longer visible in the front end when using bbPress 2.3 beta 2. this includes individual topics as well as forums lists. http://imgur.com/7Gjsvfx

This happens for all user roles, including Administrator (WP) and Keymaster (bbPress)

Users can still create topics, but once they post, they see an empty forum with no discussions. Topics and replies still exist in the backend administration and forum counts are still correct (eg "This forum contains 13 topics and 11 replies"). But discussions are just not visible in the front end. I tried switching to the default theme and repairing the settings in Settings > Forum, but the problem persists.

Attachments (1)

bbpress-2.3-beta2.jpg (68.6 KB) - added by kraigg 14 months ago.
Forum list page - no topics visible

Download all attachments as: .zip

Change History (11)

kraigg14 months ago

Forum list page - no topics visible

comment:1 johnjamesjacoby14 months ago

Sounds like you installed a plugin that's conflicting somewhere else. Can you walk through the details of how and when exactly this started happening? Does this happen with beta 1? Or with trunk (which will become beta 3?)

comment:2 kraigg14 months ago

Hi JJJ, I downloaded Beta 2 from here http://bbpress.org/blog/

As soon as I uploaded 2.3 Beta 2 into my wp-content/plugins/bbpress folder via FTP, replacing the previous 2.2.4, the problem started happening.

If I delete 2.3 Beta 2 and re-upload the current 2.2.4, the problem is resolved and topics and replies are visible again.

My administrator account has all the user roles/capabilities

comment:3 kraigg14 months ago

I havent tried it with Beta 1 and I couldn't find trunk. So I only downloaded Beta 2 from the blog page on the bbPress website.

comment:4 netweb14 months ago

What other plugins are you running?

Does it work using WordPress Twenty Eleven or Tweny Twelve themes?

Can you disable all your other plugins so only bbPress is activated, does it work now?
(Then activate each plugin one by one and test if bbPress is working after you activate each)

You can grab the /trunk version of bbPress via the 'zip archive' link at the bottom of this page:
http://bbpress.trac.wordpress.org/browser/trunk

comment:5 kraigg14 months ago

Thanks for your time and patience.

I went through a process of elimination with all my installed plugins. It turns out that bbPressModeration plugin was what was causing the display problems. I'm not really sure what changes occurred in bbPress from 2.2.4 to beta trunk version that could cause bbPressModeration to throw these errors.

Unfortunately bbPressModeration is one of my must-have plugins, so I'm not able to deactivate it. Moderation is a prerequisite for the website I administer. I may have to stick with bbPress 2.2.4 for the time being, until bbPressModeration is made compatible with bbPress 2.3.

But thanks for helping me out and helping pinpoint the cause of my errors.

comment:6 johnjamesjacoby14 months ago

  • Milestone changed from Awaiting Review to 2.3

To confirm; is this the plugin you're talking about:

http://wordpress.org/extend/plugins/bbpressmoderation/

If so, I'll do some testing with it before 2.3 is released.

comment:7 kraigg14 months ago

Thanks! Yes, that's the bbPressModeration plugin I am using. Thanks again @johnjamesjacoby

comment:8 johnjamesjacoby14 months ago

  • Component changed from General to Moderation
  • Milestone 2.3 deleted
  • Resolution set to invalid
  • Status changed from new to closed

The problem comes from the bbPressModeration::query() method. It assumes that all bbPress queries will include a 'post_status' array key, which is causing the filter to return a corrupted value, breaking the topics query. It's also as a result of bbPress switching to the smarter 'perm' query variable, rather than trying to build it's own 'post_status' array.

Thinking out loud, the plugin author may want to filter 'posts_where' instead of looking for the now deprecated 'bbp_widget' query name. That would allow for the most flexibility and backwards/forwards compatibility, since it's entirely likely that query parameters in bbPress will be tweaked over time.

Since this isn't exactly a bbPress bug, I'm closing as invalid. A few minor tweaks to the bbPress Moderation plugin will bring it up to speed for 2.3.

comment:10 netweb12 months ago

  • Cc stephen@… added
Note: See TracTickets for help on using tickets.