Skip to:
Content

#2190 closed defect (fixed)

BuddyPress: "Replies Created" pagination doesn't work under profile

Reported by: r-a-y Owned by:
Milestone: 2.3 Priority: normal
Severity: normal Version: 2.2
Component: BuddyPress Keywords: has-patch
Cc:

Description

Steps to reproduce:

  1. Make sure a user has enough total replies to cause pagination.
  2. Navigate to /members/USERNAME/forums/replies/
  3. Attempt to click on the second page in the pagination links.
  4. Pagination link looks like this:

domain.com/members/page/2/

Which is invalid; link should look like this:

domain.com/members/USERNAME/forums/replies/page/2/

Tested on trunk.

Why is this happening?

Problem occurs during the construction of the pagination links in bbp_has_replies().

Attached patch changes how the $base variable is constructed so a check is done in bbp_is_single_user() as well and moves the is_page() check lower in the stack.

This mirrors how bp_has_topics() works.

Attachments (1)

2190.01.patch (1.5 KB) - added by r-a-y 15 months ago.

Download all attachments as: .zip

Change History (3)

r-a-y15 months ago

comment:1 johnjamesjacoby15 months ago

  • Milestone changed from Awaiting Review to 2.3

comment:2 johnjamesjacoby15 months ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [4741]) Fix issue with user profile replies pagination. Props r-a-y. Fixes #2190.

Note: See TracTickets for help on using tickets.