Skip to:
Content

#2038 closed defect (fixed)

BuddyPress: Email notification links are incorrect.

Reported by: r-a-y Owned by: jmdodd
Milestone: 2.3 Priority: normal
Severity: normal Version: 2.2
Component: BuddyPress Keywords: has-patch
Cc: jmdodd@…

Description

When a user is subscribed to a BuddyPress group forum topic, the email notification link is incorrect and is missing the HTTP host from the link.

Regular forum subscription posts show the correct post link in the emails.

If no one beats me to it, I'll look into this a bit later on.

Attachments (1)

2038.1.diff (876 bytes) - added by jmdodd 17 months ago.
Move 'bbp_notify_subscribers' from 1 to 11 on 'bbp_new_reply'.

Download all attachments as: .zip

Change History (6)

comment:1 johnjamesjacoby17 months ago

  • Milestone changed from Awaiting Review to 2.2.2

Let's see about getting this into 2.2.2, as it's a bit less urgent than the roles stuff was.

comment:2 johnjamesjacoby17 months ago

  • Keywords reporter-feedback added
  • Milestone changed from 2.2.2 to 2.3

To confirm, you're saying it's missing the host/domain? I'm not sure how that could be; it uses get_permalink().

Steps to reproduce?

comment:3 r-a-y17 months ago

  • Keywords reporter-feedback removed

Hi JJJ,

I haven't looked into the codebase yet to find out what the problem is, but the issue is the link is missing the domain.

If you are using get_permalink() under a BuddyPress group, then that doesn't sound like it would work as BP doesn't follow WP's permalink structure.

Steps to reproduce:

  • Make sure BuddyPress is setup to use bbPress as the group forums
  • Make sure bbPress subscriptions are enabled
  • Navigate to a BuddyPress group forum
  • Create a new topic and check "Notify me of follow-up replies via email"
  • Login as another user, navigate to the topic and post to it.
  • The OP should receive an email with the wrong post link.

jmdodd17 months ago

Move 'bbp_notify_subscribers' from 1 to 11 on 'bbp_new_reply'.

comment:4 jmdodd17 months ago

  • Cc jmdodd@… added
  • Keywords has-patch added; needs-patch removed
  • Owner set to jmdodd
  • Status changed from new to assigned

bbp_notify_subscribers runs before bbp_update_reply on bbp_new_reply. When bbp_get_reply_topic_id() runs in bbp_notify_subscribers, it fails because the new reply's topic metadata has not been set.

includes/core/actions.php:add_action( 'bbp_new_reply',    'bbp_notify_subscribers',                 1, 5 );
includes/core/actions.php:add_action( 'bbp_new_reply',  'bbp_update_reply', 10, 6 );

comment:5 jmdodd17 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [4570]) Move bbp_notify_subscribers to priority 11.

Note: See TracTickets for help on using tickets.