Skip to:
Content

#1963 closed defect (fixed)

Custom post type menus disappear after profile update

Reported by: jaredatch Owned by:
Milestone: 2.2 Priority: normal
Severity: normal Version:
Component: Back-end Keywords:
Cc: stephen@…

Description

Editing your profile through bbPress results in the CPT menus disappearing.

Able to duplicate this on bbPress/WordPress trunk.

Test user account is admin with full admin privileges.

  • Edit your profile via yoursite.com/forums/users/admin/edit.
  • Update anything.
  • Save.
  • Go back to WordPress admin and the Forum/Topic/Reply menus are now gone.

Change History (6)

comment:1 netweb19 months ago

  • Cc stephen@… added

Confirmed with WordPress 3.5-beta1-22104 and bbPress [4230]

comment:2 anointed19 months ago

I was just coming in to post about disappearing menus for no apparent reason. Glad I found this thread as I was going insane trying to track down this bug.

Great catch figuring this out. I never ever would have guessed that editing the profile was the cause of my menus disappearing. I was going nuts as it seemed to happen for no apparent reason.

comment:3 jaredatch19 months ago

It took me a bit to track it down, trust me :P

Problem lies in bbp_save_user_caps() (bbp-core-caps.php), but I haven't played with all the new caps enough to easily figure out what's not right.

comment:4 jaredatch19 months ago

This goes along with the same bug I think.

On bbPress.org I updated my profile bio and now I am unable to reply to topics!

comment:5 johnjamesjacoby19 months ago

Yep; lame. Looking into it.

comment:6 johnjamesjacoby19 months ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [4236]) Capabilities:

  • Introduce sub-action for saving a users profile.
  • Hook capability saving functions to this new action.
  • Remove duplicate admin routine from /bbp-admin/bbp-users.php.
  • Remove hardcoded capability saving from bbp_edit_user_handler().
  • Add edit_user capability checks to cap save and reset functions.
  • Fixes bug when caps would be lost when a user saves their own profile.
  • Fixes #1963.
Note: See TracTickets for help on using tickets.