Skip to:
Content

bbPress.org

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1663 closed defect (worksforme)

Forum Participant role cannot view private forum

Reported by: mjpg Owned by:
Milestone: Priority: high
Severity: blocker Version: 2.0
Component: Component - Users Keywords:
Cc:

Description

Setup

WordPress 3.2.1; bbPress 2.0; GD bbPress Attachments 1.2.1

Summary

I have installed bbPress OK and have a single forum with a few topics/replies as a test.

The forum is for members only and so I set it to 'private' in Forum attributes > visibility.

I then created a member 'Fred Smith' and set them as a 'Forum Participant' but when I log in as them, I get an error "Oh bother! No forums were found here!".

If I set them to 'Forum Moderator' they can see the forum and topics, but then they also have moderator privilages displayed, which is not wanted.

===================================

Checking grid:

Forum = Visibility: Hidden
User = Forum Participant
Result = Oh bother! No forums were found here!

Forum = Visibility: Hidden
User = Forum Moderator
Result = Forums and topics show OK

Forum = Visibility: Private
User = Forum Participant
Result = Oh bother! No forums were found here!

Forum = Visibility: Private
User = Forum Moderator
Result = Forums and topics show OK

I also tried posting a topic as the user, but even that does not show.

===================================

WORK-AROUND

I used the WP plugin 'User Role Editor' (WP not bbp plugin)
http://wordpress.org/extend/plugins/user-role-editor/

to add some capabilities to the 'forum participant' role.

These seem to be the extra capabilities required:

[v] read_hidden_forums
[v] read_private_forums
[v] read_private_replies
[v] read_private_topics

If set up without the 'read_hidden_forums' capability, forums are visible, but not topics. I don't know if this is real or because I have been switching the hidden/private setting for the forum during testing.

=====================================

Also discussed here:
http://bbpress.org/forums/topic/forum-participant-role-cannot-view-private-forum

Thanks

Change History (2)

#1 @johnjamesjacoby
8 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

This is by design. The "Forum Participant" is a role traditionally used only in multisite installations to provide proper caps to global forums where users do not otherwise have authority. It's capabilities match those of the basic subscriber to not leak out private or hidden forum data.

#2 @johnjamesjacoby
8 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.