Skip to:
Content

bbPress.org

Opened 10 years ago

Closed 10 years ago

#1641 closed defect (bug) (worksforme)

Strange breadcrumbs logic

Reported by: pavelevap Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.0
Component: Component - Forums Keywords: reporter-feedback
Cc: pavelevap@…

Description

I have set up my Page "Forum" as main index page for bbPress.
But after clicking on this page (localhost/forum), I get following strange breadcrumbs:

Home › Forums › Forum

It is a little strange because Home (localhost) is base URL (web homepage), then there is Forums (localhost/forums, archive for forums) and the last is Forum (localhost/forum, page with selected archive template). There is no hierarchy and logic as suggested in breadcrumbs... Maybe Forums should be removed from breadcrumbs for this case (displaying page)?

Change History (3)

#1 @johnjamesjacoby
10 years ago

  • Keywords reporter-feedback added
  • Milestone changed from Awaiting Review to 2.1

If you peek at the breadcrumb logic, there is quite a bit of code in there to prevent this from happening already.

I imagine the problem is that you did not set your forum root slug to match the 'forum' page slug. You are allowed to have them be different if you choose. If you do, this will happen by design.

If that's not the case, this is something specific to your installation and I'll need more details to be able to hunt down the cause.

#2 @pavelevap
10 years ago

Yes, thank you! It is only my wrong logic :-)

I did not know that it is recommended to unify forums base slug with selected page slug. It really makes sense now, but me and two other users did not even notice this possibility. Maybe there should be help notice above forums base slug (settings) or automatic script somehow related to page save action to set up forums base slug automatically when forums index page template is selected?

#3 @johnjamesjacoby
10 years ago

  • Milestone 2.1 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Really no way to automate this, since as a site admin you have the ability to configure your site however you wish. To automate it would be to limit it's functionality. If someone dreams up an amazing patch that makes this more obvious, I'm all for it. :)

Closing as workforme.

Note: See TracTickets for help on using tickets.