Skip to:
Content

Opened 20 months ago

Closed 20 months ago

Last modified 20 months ago

#3119 closed defect (invalid)

Missing roles for imported users

Reported by: sourfew Owned by:
Milestone: Priority: normal
Severity: normal Version: trunk
Component: API - Importers Keywords:
Cc:

Description

bbpress 2.6 rc3
wordpress 4.7.5

Imported users and posts from Vbulletin 4.2.2

No user is assigned any site or forum role.

Change History (6)

#1 @netweb
20 months ago

  • Component changed from General to API - Importers
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Thanks @sourfew Roles are not assigned to users during import, this is by design and due to the fact that there is a vast array of roles and altered custom roles available via vBulletin so there's no easy way to map those.

Instead, when an imported user logs in for the first time they are automatically assigned the bbPress role "Participant"

#2 @sourfew
20 months ago

Ok, thanks. I did an import with an earlier version of bbpress and that time all roles were set thats why I asked.

#3 follow-up: @netweb
20 months ago

The bbPress importers have never set roles for imported users...

#4 @espellcaste
20 months ago

I'd like to confirm what @netweb is saying. I used the import feature in the past and it didn't imported the users and its roles.

#5 in reply to: ↑ 3 @sourfew
20 months ago

Replying to netweb:

The bbPress importers have never set roles for imported users...

The import that have roles set is from a xenforo import with bbpress 2.6 beta2. Can it be importer dependent?

#6 @johnjamesjacoby
20 months ago

The only time roles were ever copied over was old BuddyPress forums that used bbPress 1.x. Those used to import the old bbPress 1.x roles, but they haven't since 2.1.

Thanks everyone for being on top of this. The importer could do a better job saying "You may want to go run these tools next."

Note: See TracTickets for help on using tickets.