Skip to:
Content

Opened 4 years ago

Closed 2 years ago

#2754 closed defect (worksforme)

Post do not moving if it was sticky

Reported by: rrrFer Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5.4
Component: Component - Forums Keywords: 2nd-opinion
Cc: rrrfer@…

Description

Try make post sticky and then move it to another forum.
Post will be created on new forum, but it rest on old forum.

Change History (4)

#1 @rrrFer
4 years ago

  • Cc rrrfer@… added
  • Component changed from General to Component - Forums

#2 follow-up: @thebrandonallen
3 years ago

  • Keywords 2nd-opinion added
  • Milestone changed from Awaiting Review to 2.6

Confirmed.

There are a couple of things going on here:

  1. When we move topics, we don't remove it from the super stickies. This seems like the correct approach, since super stickies are sticky in every forum.
  2. We you stick a topic from the topic page, we default to it being a super sticky. This seems like the wrong approach.

I haven't personally used sticky topics that much, but when testing this, I wasn't expecting the topic to automatically be a super sticky topic. I expected it to stick only to it's current forum. In fact, the language in the admin list table suggests that it will only be stuck to it's forum, however, it's actually makes it super sticky.

To note: Everything works as expected when you move a regular sticky topic to another forum.

I'll write a patch, and add some tests, but I want to make sure I seeing things correctly.

#3 in reply to: ↑ 2 @netweb
3 years ago

Replying to thebrandonallen:

I wasn't expecting the topic to automatically be a super sticky topic. I expected it to stick only to it's current forum. In fact, the language in the admin list table suggests that it will only be stuck to it's forum, however, it's actually makes it super sticky.

In the list table it is actually two links, 1, Stick, and 2 (to front), the HTML:

<span class="stick">
<a href="/wp-admin/edit.php?post_type=topic&amp;topic_id=119&amp;action=bbp_toggle_topic_stick&amp;_wpnonce=aaaa59aaaa" title="Stick this topic to its forum">Stick</a> 
<a href="/wp-admin/edit.php?post_type=topic&amp;topic_id=119&amp;action=bbp_toggle_topic_stick&amp;super=1&amp;_wpnonce=aaaa59aaaa" title="Stick this topic to front">(to front)</a> | 
</span>

#4 @johnjamesjacoby
2 years ago

  • Milestone 2.6 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

What @thebrandonallen and @netweb concluded is correct.

Closing as works for me.

Note: See TracTickets for help on using tickets.