Skip to:
Content

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#925 closed defect (wontfix)

Can't delete topics and posts

Reported by: wiseacre Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.0-alpha-1
Component: Administration Keywords:
Cc:

Description

I Alpha 1 and rev 1648 too I
1 Create some new topic
2 Post in some topic
3 Delete one post
4 Delete some entire topic
5 Go to Manage/Topics
6 All deleted topics and posts are here

OK, that's good feature. But I (the good old key master) can't remove deleted topics and posts from the database.

I am using FF 3.0.1 and kUbuntu 8.04.

Change History (7)

comment:1 in reply to: ↑ description wiseacre6 years ago

I forgot (5:38 AM for me)

PHP 4.4.8 and 5.0 with .htaccess
mysql Ver 14.7 Distrib 4.1.22, ...

comment:2 sambauers6 years ago

  • Milestone 1.0-beta & XML-RPC deleted
  • Resolution set to invalid
  • Status changed from new to closed

This is a feature, not a bug.

If you want to delete for good, then use phpMyAdmin or another direct SQL method.

comment:3 wiseacre6 years ago

  • Milestone set to 1.0-beta & XML-RPC

Collecting rubbish in the database can't be feature

comment:4 wiseacre6 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:5 fel646 years ago

It'd be a nice feature if the ability to delete from the database was available too (especially with a pseudo-cron implemented rolling delete of older-than-specified stuff).

comment:6 sambauers6 years ago

  • Resolution set to wontfix
  • Status changed from reopened to closed

This is a safety net to stop teh same unique id being used twice on topics and posts and users.

This can occur when admins migrate from one database to another and somehow reset the auto_increment on the unique id.

We won't be adding "real" topic/post deletion in core. Some people don't like having "dead" data in their database, but it really has little to no effect on the operation of the application.

Having said that it can be done via plugin if you really want it.

Sorry, back to wontfix.

comment:7 sambauers6 years ago

  • Milestone 1.0-beta & XML-RPC deleted
Note: See TracTickets for help on using tickets.