Skip to:
Content

bbPress.org

Opened 13 years ago

Closed 12 years ago

#732 closed enhancement (wontfix)

bbPress needs a per forum permissions structure

Reported by: _ck_ Owned by:
Milestone: Priority: normal
Severity: normal Version: 0.8.2.1
Component: Back-end Keywords:
Cc:

Description

Just like users have roles with permissions, bbPress needs a structure for each forum (as every mature forum program has). This makes tasks like private forums and read-only forums incredibly easier. In the future you are adding trackback/ping ability - what if you only want that ability on one individual forum and block it for the rest? etc.

Imagine the task for making one forum out of several read-only. This task becomes virtually impossible without hacking the core. If there was a serialized array as a column in the forums table, it becomes trivial to add

bb_set_forum_can_be_read(3,'participate') bb_set_forum_can_be_written(3,'moderate')

In that example you'd have to be logged in to read the forum, and a moderator or above would be able to write to it.

Along this line of thought, in addition to permissions per forum, forums also need their own metadata table for columns you cannot yet invision that plugins might want to add. For example recalculating views per forum everytime a page is loaded is an "expensive" mysql/cpu task. It should be stored in metadata.

(It's suggested right inside the bbpress code that maybe the first test if the forums table exists that it should just be loaded at that point directly into the cache - I agree!)

Change History (7)

#1 @fel64
13 years ago

Well yeah. This enhancement is pretty well known.

http://trac.bbpress.org/ticket/155
http://trac.bbpress.org/ticket/493
http://trac.bbpress.org/ticket/515

But the forums-meta is something else, as is the directly loading the forums. Should make seperate tickets for those, I'll make one for forums meta now.

#2 @fel64
13 years ago

Oh, no I won't - there's one already.
http://trac.bbpress.org/ticket/707 Talk there \o/

#3 @mdawaffe
13 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

#4 @richcon
13 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Is this really a duplicate of those two tickets? #459 is to add fine-grained moderation rights to users (user x can moderate forum y), this ticket is to add permissions information to forums based on user level (forum x can be ready by user level y). They seem different to me.

#707 seems more like a dependency than a duplicate. Per-forum metadata (707) might be a good place to store permissions information, but it's not the creation of a permissions structure itself.

#5 @sambauers
13 years ago

  • Milestone set to 0.8.5 & XML-RPC

#6 @sambauers
13 years ago

Forum meta added in [1528], [1529], [1530]

#7 @sambauers
12 years ago

  • Milestone 1.0-beta & XML-RPC deleted
  • Resolution set to wontfix
  • Status changed from reopened to closed

Individual forum permissions won't be added in 1.0

The meta tableis there for anyone who want's to do this with a plugin.

Note: See TracTickets for help on using tickets.