Skip to:
Content

Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#588 closed defect (fixed)

Login Redirect Loop

Reported by: Trent Owned by:
Milestone: 1.0 Priority: normal
Severity: normal Version: 0.9.0.2
Component: Front-end Keywords:
Cc:

Description

The bbPress forums has a redirect error on it if you use the top login
form on bb-login.php. I cannot replicate this error on any other
installation but the bbPress Support forums, but marky reported this happens
on his default install as well. It happens in all major
OS and browers that I use.

http://bbpress.org/forums/bb-login.php

Referenced by chrishajer at:

http://bbpress.org/forums/topic/719
http://bbpress.org/forums/topic/745

Trent

Change History (7)

comment:1 so1o7 years ago

check if the template that you are using has this changeset [556] fixed..

http://trac.bbpress.org/changeset/556

comment:2 Trent7 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Still doesn't work in the forums at bbpress.org/forums/

Tested it on my install with the default template and it works (I have latest TRAC). Works on all my other templates as well. Seems like this is only happening on the bbPress forums as we haven't updated it to the latest TRAC yet (past 556). This problem will be fixed with the next release in my mind, so I am marking this as "worksforme" until someone can reproduce this when 1.0 actually comes out.

Trent

comment:3 so1o7 years ago

  • Milestone set to 1.0

yes on the forum it might not work because the template is old.

Even if some one can reproduce it, refer them to the changeset and ask them to make those same changes. if that doesnt fix it - we can look at on case basis.

comment:4 Trent7 years ago

The template may be old, but if it is setup with only the files needed for the template, it should work as my 'copy' of the bbPress forums template works. That is a good reason to stress that theme developers include the files that are required to change the theme and not all of them!

Cheers,

Trent

comment:5 finalwebsites6 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Version changed from 0.8 to 0.9.0.2

Using a template with the hidden form field is not the solution.

if you're not "logged in" and you try add a new topic the varaible "re" doesn't have the right value. This happens only if you click this from the forum or tag list.

Result after login you get an error (the login session is created).

check also my post on the forum:
http://bbpress.org/forums/topic/redirect-after-login-error

comment:6 sambauers6 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [1759]) Suppress warnings when bb_safe_redirect() is passed a bad URL. Fixes #588 again.

comment:7 sambauers6 years ago

(In [1760]) Rename new_topic() to bb_new_topic_link() and always pass full URLs from it as well. See #588

Note: See TracTickets for help on using tickets.