Skip to:

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#575 closed defect (fixed)

bb_get_stylesheet_uri() isn't going to the correct location

Reported by: Epsilon Owned by: mdawaffe
Milestone: 0.8.1 Priority: high
Severity: normal Version: 0.8
Component: Front-end Keywords:


My stylsheet doesn't seem to be pointing to the right location; when it should be going to "" it goes to "http:/''". Under the presentation field, the thumbnail does not show correctly as well, but not in the same way that the stylesheet URL did, "", duplicating the domain twice. Otherwise, all links and URLs work fine.

Attachments (2)

path-to-url.php (166 bytes) - added by mdawaffe 9 years ago.
Plugin to fix
path-to-url.2.php (232 bytes) - added by mdawaffe 9 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 @mdawaffe9 years ago

  • Milestone set to 1.0
  • Owner set to mdawaffe
  • Status changed from new to assigned

It's a problem with bb_convert_path_base(). Apparently that function is a little too greedy.

@mdawaffe9 years ago

Plugin to fix

comment:2 @mdawaffe9 years ago

Try out the attached plugin until this gets fixed in the next version.

comment:3 @mdawaffe9 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [703]) fix for bb_convert_path_base() when server path has url domain in it. Fixes #575

@mdawaffe9 years ago


comment:4 @mdawaffe9 years ago

  • Milestone changed from 1.0 to 0.8.1
Note: See TracTickets for help on using tickets.