Skip to:
Content

bbPress.org

Opened 3 months ago

Closed 3 months ago

#3391 closed enhancement (duplicate)

Move topic to an other forum

Reported by: peterkueger Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Cc:

Description

I can move a reply to another topic. But there is no admin link to move a topic to another forum.

I can click to the adminbar "Edit topic" button and move it there. But if I do this, the forum overview (number of topics) will not be updated.

@johnjamesjacoby:
Are you interested that I try to implement this? If yes, how should I submit this to you? (I don't know, how to submit pull requests to bbPress.)

Attachments (1)

jjj-sc-2020-08-16 at 15.59.58@2x.png (131.4 KB) - added by johnjamesjacoby 3 months ago.

Download all attachments as: .zip

Change History (5)

#1 @casiepa
3 months ago

@peterkueger Have a look at my https://wordpress.org/plugins/bbp-move-topics/ if you look for inspiration. I haven't tested it with 2.6 yet, but it will probably still do the trick.

#2 @johnjamesjacoby
3 months ago

  • Milestone changed from Awaiting Review to Under Consideration

You can currently move a Topic via its "Edit" page.

I've never considered whether Topics should match Replies in this regard.

The reason they are different, is because there are usually fewer Forums than there are Topics, and it would be inefficient to load every Topic when editing a Reply, so a dedicated "Move" page was created for this.

It would be nice to abolish the Reply "Move" and "Split" pages completely and have them be part of the "Edit" page, but I suspect that would require some kind of AJAX based Topic search & picker UI, and we've always tried to keep the theme-side JavaScript to a minimum for the sake of theme compatibility.

#3 follow-up: @peterkueger
3 months ago

You can currently move a Topic via its "Edit" page.

Ok, I didn't find out this. This way is Ok for me. Thank you for that.

But I've tried again "my" other way: Click to the "Edit Topic" button inside the WordPress AdminBar and changed the forum of the topic inside the "Edit Post" page of WordPress. This still does not update the forum overview (number of topics / replies inside the single forum). So still I believe, this could be a bug?

#4 in reply to: ↑ 3 @johnjamesjacoby
3 months ago

  • Milestone Under Consideration deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2850.

Replying to peterkueger:

This still does not update the forum overview (number of topics / replies inside the single forum). So still I believe, this could be a bug?

Known issue, slated to be fixed in 2.7.

https://bbpress.trac.wordpress.org/ticket/2850#comment:3

Going to close this issue as a duplicate. Thanks again @peterkueger.

Note: See TracTickets for help on using tickets.