Skip to:
Content

bbPress.org

#3361 closed enhancement (duplicate)

Full switch from rel nofollow to rel ugc

Reported by: SirLouen Owned by:
Milestone: Priority: low
Severity: minor Version:
Component: API - Formatting Keywords:
Cc:

Description

Considering that WP core from 5.3 has started using UGC, I think that to stay compliant bbpress shall move to this format

https://make.wordpress.org/core/2019/10/03/wp-5-3-introduces-new-functions-to-add-ugc-attribute-to-links-and-implements-it-to-comments/

Essentially the fix is as simple as replacing bbp_rel_nofollow function to bbp_rel_ugc and the parts "nofollow" to ugc in includes/common/formatting.php

Then this can be moved to all filters within includes/core/filters.php and the bbp_rel_nofollow in includes/core/functions.php for the profile links also in the templates (templates/default/bbpress/user-profile.php

If this approved I can try to provide a patch.

Change History (1)

#1 @johnjamesjacoby
10 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3318.

Hi @SirLouen, closing your issue in favor of an earlier one.

If you would like to make this patch, please feel free to do so over there.

Thank you!

Note: See TracTickets for help on using tickets.