Skip to:
Content

bbPress.org

Opened 16 months ago

Closed 6 months ago

#3350 closed defect (maybelater)

Actions in `BBP_Topic_Replies_List_Table::get_bulk_actions()` are unreachable.

Reported by: itowhid06 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General - Administration Keywords: has-patch
Cc:

Description

An empty array has been returned just before returning the actions array!

Attachments (1)

3350.diff (578 bytes) - added by itowhid06 16 months ago.

Download all attachments as: .zip

Change History (2)

@itowhid06
16 months ago

#1 @johnjamesjacoby
6 months ago

  • Component changed from General to General - Administration
  • Milestone Awaiting Review deleted
  • Resolution set to maybelater
  • Status changed from new to closed

Hello @itowhid06, thanks for the patch.

Unfortunately, this is currently working as intended, and your patch will only introduce some potential problems.

This method exists in this class to nullify the bulk actions that can be taken here. The array underneath it exists as a @todo to be worked on later.

  1. These bulk actions need capability checks to ensure that the current user can perform them
  2. $this->bulk_actions() is never called so nothing is ever output
  3. No bulk-action check-boxes are output to take bulk actions on

Going to close this ticket, since the amount of work to implement bulk actions here is somewhat significant, and also isn't the focus of this report specifically.

Thank you again for noticing this! Please continue to contribute your findings.

Note: See TracTickets for help on using tickets.