Skip to:
Content

bbPress.org

#3348 closed enhancement (maybelater)

[bbp-forum-index] display only 50 forums !

Reported by: poco06 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Component - Forums Keywords:
Cc:

Description

Hello,

I'm using bbpress with the DIVI theme and got an issue : the [bbp-forum-index] shortcode returns only 50 forums end no more !
I have also tried with the Twenty Twenty theme and got the same issue.

Any idea how I could display more than 50 forums with this shortcode?

Regards
Pat

Change History (1)

#1 @johnjamesjacoby
11 months ago

  • Component changed from General to Component - Forums
  • Milestone Awaiting Review deleted
  • Resolution set to maybelater
  • Status changed from new to closed
  • Type changed from defect to enhancement

Hello @poco06. Thanks for making this ticket here.

This is by design. It is simply an "upper boundary" to keep Forum queries as efficient at they can be, because there is no pagination for Forums, they are always all dumped out for whatever branch in the tree is being shown.

You can update the _bbp_forums_per_page option in the database to whatever higher number that you'd like to. It's not perfect, but it will allow you to raise that limit to something more appropriate for your site.

Note: See TracTickets for help on using tickets.