Skip to:
Content

bbPress.org

Opened 3 years ago

Closed 4 weeks ago

#3187 closed defect (duplicate)

Incorrect Freshness if a forum is empty

Reported by: kfoubert Owned by: johnjamesjacoby
Milestone: Priority: high
Severity: major Version:
Component: Component - Forums Keywords:
Cc:

Description

The Freshness of a category is not being displayed correctly if a Category Forum has three or more sub-forums and one of the forums has NO topics. It appears a sort order is not factored in for freshness. I have screenshots of the site, since it requires a login that is only accessible after purchasing a membership.

Here's an example:

Forums Landing Page
path: /forums/

A forum category with a bad freshness date
AFMCP Discussion Forums 166 topics, 346 posts. Freshness = 2 years, 6 months ago

If I view "AFMCP Discussion Forums" the 2 years, 6 months is coming from the archived forums, but there are other forums that have a more recent date, and there are 2 forums that have 0 topics.

AFMCP Discussion Forums Landing Page
AFMCP 2017 June – Washington DC 6 topics, 9 posts, Freshness 1 month, 2 weeks ago
AFMCP 2017 September – Dallas, TX 12 Topics, 19 Posts, Freshness 3 months ago
AFMCP 2017 November – Chicago, IL 17 Topics, 34 Posts, Freshness 1 month ago
AFMCP 2018 March – San Diego, CA 0 Topics, 0 Posts, Freshness No Topics
AFMCP 2018 October – Washington DC 0 Topics, 0 Posts, Freshness No Topics
Archived Posts 131 Topics, 284 Posts, Freshness 2 years, 6 months ago

SOLUTION
On my development test server, once I added topics to AFMCP 2018 March and AFMCP 2018 October, the correct freshness date started showing.

Attachments (2)

Forums Archive.png (334.0 KB) - added by kfoubert 3 years ago.
Forum Landing Page - Highlighted example forum with bad freshness
AFMCP Discussion Forum.png (254.1 KB) - added by kfoubert 3 years ago.
Category View - shows how freshness date is pulling from old archives forum

Download all attachments as: .zip

Change History (9)

@kfoubert
3 years ago

Forum Landing Page - Highlighted example forum with bad freshness

@kfoubert
3 years ago

Category View - shows how freshness date is pulling from old archives forum

#1 @johnjamesjacoby
3 years ago

  • Component changed from General to Component - Forums
  • Keywords needs-testing added
  • Milestone changed from Awaiting Review to 2.6.1
  • Owner set to johnjamesjacoby

Thanks for the report. I’ll take a look at this in a few days. I’m not exactly sure why this would happen, and it could be a few different things.

Moving into 2.6.1 to look into it after 2.6 goes out.

#2 @johnjamesjacoby
8 months ago

  • Milestone changed from 2.6.1 to 2.6.2

Move these to 2.6.2.

#3 @johnjamesjacoby
8 months ago

  • Keywords needs-patch added
  • Milestone changed from 2.6.2 to 2.6.3
  • Priority changed from normal to high
  • Severity changed from normal to major

This issue is still on our radar to fix. Unfortunately other more urgent fixes keep being necessary.

Moving to 2.6.3.

#4 @johnjamesjacoby
7 months ago

  • Milestone changed from 2.6.3 to 2.6.4

#3297 is likely a duplicate of this, but let's try and figure this out in 2.6.4.

#5 @johnjamesjacoby
5 months ago

  • Milestone changed from 2.6.4 to 2.6.5

Moving open issues from 2.6.4 to 2.6.5, for 2.6.4 release today.

#6 @johnjamesjacoby
6 weeks ago

  • Milestone changed from 2.6.5 to 2.6.6

#7 @johnjamesjacoby
4 weeks ago

  • Keywords needs-testing needs-patch removed
  • Milestone 2.6.6 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

My testing strongly suggests this was fixed via #3376.

Let's see if 2.6.6 resolves this for you, and reopen for 2.6.7 if not.

(I'm closing this ticket as a duplicate of that one. It's backwards, and not really ideal, but those commits are already completed and in, so it doesn't make sense to undo that work here. Sorry for the incongruity.)

Note: See TracTickets for help on using tickets.