Skip to:
Content

#3165 closed defect (fixed)

Fix BBP_Forums_Group_Extension::is_single_forum

Reported by: thebrandonallen Owned by: johnjamesjacoby
Milestone: 2.6 Priority: normal
Severity: normal Version: trunk
Component: Extend - BuddyPress Keywords: has-patch
Cc:

Description

In BBP_Forums_Group_Extension::is_single_forum there are two issues preventing it from function properly.

  1. We're checking the $this->forum_slug is the first key in BuddyPress::action_variables. $this->forum_slug isn't a property that's set.
  2. We're that the first value in BuddyPress::action_variables is set to forum, but this will never be the case because it's shifted off the action variables array to become BuddyPress::current_action

Found this randomly on a site where I've been running trunk. The BBP stylesheet wasn't being loaded on BP group forum pages that were paged. This may also fix a few more edge cases for comment:4:ticket:3138.

Attachments (1)

3165.01.diff (625 bytes) - added by thebrandonallen 20 months ago.

Download all attachments as: .zip

Change History (3)

#1 @johnjamesjacoby
20 months ago

  • Owner set to johnjamesjacoby

Confirmed. Thanks for the patch! Will get this committed asap.

#2 @johnjamesjacoby
20 months ago

  • Resolution set to fixed
  • Status changed from new to closed

In 6710:

BuddyPress: improve targeting of single forum/topic filters.

This change simplifies the logic used when attaching-to and checking-for the current BuddyPress Group Forum & Topic pages, by conditionally filtering behind a singular bp_is_group() check.

Fixes #3165. Props thebrandonallen.

Note: See TracTickets for help on using tickets.