Skip to:
Content

bbPress.org

Opened 3 years ago

Closed 6 weeks ago

#3157 closed feature (fixed)

Add forum role when adding new/existing users

Reported by: johnjamesjacoby Owned by: johnjamesjacoby
Milestone: 2.6.5 Priority: normal
Severity: normal Version:
Component: Component - Users Keywords:
Cc:

Description

When adding or inviting a user to a site, it would be nice to include the bbPress forum along with the site/blog one. With actions introduced back in WordPress 3.7, this is now possible (it wasn't the last time I looked, yikes.)

Attachments (1)

Screen Shot 2017-08-30 at 12.10.43 AM.png (245.0 KB) - added by johnjamesjacoby 3 years ago.
Form field added (single site)

Download all attachments as: .zip

Change History (8)

#1 @johnjamesjacoby
3 years ago

  • Owner set to johnjamesjacoby
  • Type changed from enhancement to feature

#2 @johnjamesjacoby
3 years ago

In 6675:

Users: first pass at forum role selection on invite/add-new.

This change adds the ability to set a specific forum role when adding a new user. If no valid role is found or saved, the default role will be used by default. There is likely more to do here, to ensure auto-role continues to work as intended as well.

Trunk, for 2.6. See: #3157.

@johnjamesjacoby
3 years ago

Form field added (single site)

#3 @johnjamesjacoby
3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

OK. I think this is working as intended.

It might need more testing with weirder multisite setups, or with BuddyPress on single-site and a custom WP Signups table, but we can work on those integrations later if something comes up.

#4 @johnjamesjacoby
6 weeks ago

  • Milestone changed from 2.6 to 2.6.5
  • Resolution fixed deleted
  • Status changed from closed to reopened

A number of improvements are necessary to this feature, so this issue is being reopened to track commits in the current milestone.

#5 @johnjamesjacoby
6 weeks ago

In 7086:

Signups: Ensure that the dynamic role exists before setting it.

This commit introduces several new helper functions for validating Forum roles before saving & assigning them to new user accounts.

It also adds relevant capability checks to prevent unauthorized users from performing role assignments.

In trunk, for 2.7.0.

See #3157.

#6 @johnjamesjacoby
6 weeks ago

In 7087:

Signups: Ensure that the dynamic role exists before setting it.

This commit introduces several new helper functions for validating Forum roles before saving & assigning them to new user accounts.

It also adds relevant capability checks to prevent unauthorized users from performing role assignments.

In branches/2.6, for 2.6.5.

See #3157.

#7 @johnjamesjacoby
6 weeks ago

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.