Skip to:
Content

Opened 7 months ago

Closed 6 months ago

#3049 closed defect (worksforme)

setting forums root to 'index' causes 404 error in 2.6 beta-2

Reported by: Robin W Owned by:
Milestone: Priority: high
Severity: normal Version:
Component: API - Rewrite Rules Keywords: needs-testing reporter-feedback
Cc:

Description

I just happened to have my forums root slug set to 'index' when I tried 2.6 beta, and this causes a 404 error.

Anything else seems to work, and not an issue for me, this was set to this as a bbpress user had this setting some time ago, and I'd not reset it.

Change History (5)

#1 @johnjamesjacoby
7 months ago

  • Component changed from General to API - Rewrite Rules
  • Keywords needs-testing added
  • Milestone changed from Awaiting Review to 2.6
  • Priority changed from normal to high

I can't remember the last time the code around this setting was changed, so this will need some digging.

Maybe the rewrite rules didn't get flushed; hopefully it's that easy.

#2 @netweb
7 months ago

  • Keywords reporter-feedback added

I'm not able to reproduce using index as the forums slug _bbp_root_slug

http://src.wordpress-develop.dev/index/
http://src.wordpress-develop.dev/index/forum/test-forum/
http://src.wordpress-develop.dev/index/topic/test-topic/

@robin-w Can you try flushing the permalinks without changing any settings and see if that resolves the issue, if not could you drop a copy of what your _bbp_* option values from your wp_options database table and I'll try to reproduce the issue using your same settings.

#3 follow-up: @Robin W
6 months ago

  • Resolution set to fixed
  • Status changed from new to closed

yes, resetting permalinks fixed - thanks guys !

#4 in reply to: ↑ 3 @netweb
6 months ago

  • Milestone 2.6 deleted
  • Resolution fixed deleted
  • Status changed from closed to reopened

Replying to Robin W:

yes, resetting permalinks fixed - thanks guys !

Awesome, thanks @robin-w

Note: Reopening the ticket so as to change the resolution from "fixed" to "worksforme", see #meta2508

#5 @netweb
6 months ago

  • Resolution set to worksforme
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.