Skip to:
Content

Opened 3 months ago

Closed 2 months ago

#3037 closed defect (fixed)

BuddyPress' now requires PHP 5.3, BP's PHPUnit tests shouldn't run on unsupported versions of PHP

Reported by: netweb Owned by: netweb
Milestone: 2.6 Priority: normal
Severity: normal Version:
Component: Tools - Unit Tests Keywords: has-patch commit
Cc:

Change History (3)

#1 @netweb
3 months ago

  • Owner set to netweb
  • Resolution set to fixed
  • Status changed from new to closed

In 6204:

Unit Tests: Don't run BuddyPress PHPUnit tests on versions less than PHP 5.3.0

BuddyPress 2.8 has dropped support for PHP 5.2.x, this changeset updates the BuddyPress PHPUnit configuration to only run the tests on PHP versions greater than 5.3.0

See also https://bpdevel.wordpress.com/2016/07/21/php-5-2-bp-2-8-and-php-support-guidelines/

Fixes #3037.

#2 @netweb
2 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

In r6204 BuddyPress is still be loaded when using PHP 5.2, new fix incoming.

#3 @netweb
2 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 6217:

Unit Tests: Don't run BuddyPress PHPUnit tests on PHP 5.2.x

Previously r6204 attempted to skip BuddyPress tests if the PHP version was less than 5.3.0, this didn't work as intended as BuddyPress was still being loaded, the change would have only skipped tests rather than completely excluding the BuddyPress PHPUnit test suite from running on PHP versions less than 5.3.0.

This changeset reverts r6204 and separates the grunt test tasks into individual WordPress and BuddyPress PHPUnit Grunt tasks, this gives us the ability to explicitly exclude BuddyPress PHPUnit test suite from running on PHP 5.2.

See also https://bpdevel.wordpress.com/2016/07/21/php-5-2-bp-2-8-and-php-support-guidelines/

Fixes #3037.

Note: See TracTickets for help on using tickets.