Skip to:
Content

Opened 2 years ago

Closed 2 years ago

#2919 closed defect (duplicate)

BP Notification missing return

Reported by: designbymerovingi Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Extend - BuddyPress Keywords:
Cc:

Description

The bbp_format_buddypress_notifications function does not return anything if $action is not 'bbp_new_reply'. As the bp_notifications_get_notifications_for_user filter is a filter, the first argument should always be returned.

Adding in:

return $action;

at the end of the function resolves this.

Change History (1)

#1 @thebrandonallen
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2665. Fixed in [5512].

Note: See TracTickets for help on using tickets.