Skip to:
Content

Opened 4 years ago

Last modified 13 months ago

#2829 reopened defect

Empty "Topics started" and "Replies created"

Reported by: mfiguerasma Owned by:
Milestone: 2.7 Priority: normal
Severity: normal Version:
Component: Component - Users Keywords: needs-patch needs-unit-tests
Cc:

Description

Hello,

My Participant test user have access to private forums (not hidden ones)
He creates topics and replies, but when he access to "Topics started" or "Replies created" the result is "You have not created any topics." and "You have not replied to any topics."

I can see that query.php->get_posts() filters the private forums, but the user have the current_user_can('read_private_forums') permission so he might see them.

The action do_action_ref_array( 'pre_get_posts', array( &$this ) ) in get_posts() launches the forum/functions.php->bbp_pre_get_posts_normalize_forum_visibility() function, which excludes the forums with the call to bbp_exclude_forum_ids( 'meta_query' )

This function uses the bbp_get_hidden_forum_ids() result as the hidden forums to hide, and it gets the _bbp_hidden_forums option, which calls again the bbp_pre_get_posts_normalize_forum_visibility() when it's first calculated (or recalculated when you call bbp_repair_forum_visibility())

But here the function returns an array with {"private"} when you restore private forums and {"private","hidden"} when you restore hidden forums, so both kind of forums are included in bbp_get_hidden_forum_ids() and I can see nothing in "Topics started" list.

I can see no solution and it's hard to believe that anybody has ever had this problem.

Could you help me? I've found nothing in forums and I don't want to touch the core if it's not necessary...

Thanks,

Change History (14)

#1 @mfiguerasma
4 years ago

I've done a new, clean WP installation.
Only WP, BP and bbP, all the last versions.
One admin (keymaster) user, one regular (participant) user.
Two forums: public one and private one.
The participant creates a topic and a reply in both of the forums.
Go to his own activity page, Forums section, and only the public forum is displayed.
I assume this is a bug, it's a nosense that a user cannot see his own created data in his own activity page.
If I only work with private and hidden forums, this section will always be empty!
I'm not able to understand this behaviour...

#2 @APChicago
3 years ago

Was there any resolution on this issue? I have the same issue: participants cannot see their own private conversations started/replies/favorites/etc.

Last edited 3 years ago by APChicago (previous) (diff)

#3 @mfiguerasma
3 years ago

Not at all, I did a patch to my own site, but I'd agree an answer from the authors to know if it's a bug or the regular behavior (and, if so, why??)

#4 @thebrandonallen
3 years ago

  • Component changed from Component - Forums to Component - Users
  • Priority changed from high to normal
  • Severity changed from major to normal

Replied to your topic in the support forum. Let's have the conversation there for now.

https://bbpress.org/forums/topic/empty-topics-started-and-replies-created-hides-private-forums-data/#post-168306

#5 @netweb
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed
  • Version 2.5.7 deleted

Going to close this for now and follow the forum discussion, if it turns out to be a bug please reopen the ticket

#6 @PieterPieterDrum
3 years ago

  • Component changed from Component - Users to Component - Forums
  • Milestone set to bbPress.org
  • Priority changed from normal to high
  • Resolution worksforme deleted
  • Severity changed from normal to critical
  • Status changed from closed to reopened

#7 @PieterPieterDrum
3 years ago

Still not solved. Major problem, it is a basic feature of a forum, to see your topics.
P.

#8 @netweb
3 years ago

  • Component changed from Component - Forums to Component - Users
  • Milestone changed from bbPress.org to Awaiting Review
  • Priority changed from high to normal
  • Severity changed from critical to normal

At the moment we cannot reproduce this so please help us help you with some detailed steps to reproduce the issue :)

e.g.

  1. Using WordPress 4.3, bbPress 2.5.8, BuddyPress 2.3.4
  2. Enable BuddyPress group foums
  3. Create a BuddyPress group "xyz"
  4. A user "123" with the bbPress role "participant" and in the BuddyPress group "abc"
  5. User "123" does this
  6. Another test user does this
  7. etc...
  8. etc....

Results: This happened

Expected Results: This is what I expected to happen

#9 @mlwilkerson
3 years ago

I just posted a summary with repro steps over on the corresponding support forum thread here:

https://bbpress.org/forums/topic/empty-topics-started-and-replies-created-hides-private-forums-data/#post-177193

I did this with WordPress 4.6, BuddyPress 2.6.2, bbPress 2.5.10.

#10 @thebrandonallen
3 years ago

  • Keywords needs-patch needs-unit-tests added

Related #2191

#11 @johnjamesjacoby
21 months ago

In 6495:

Repairs: Prefer empty() over ! isset() in bbp_admin_repair_group_forum_relationship()

The meta_value key will always be set, because of the way the forum query is written.

See #2829.

#12 @johnjamesjacoby
21 months ago

In 6496:

Tools: Change BuddyPress group forum repair into an upgrade routine.

This is only intended as a migration path from bbPress 1.x to 2.x, not to be rerun multiple times to force-recount the meta values & private/hidden options.

See #2829.

#13 @johnjamesjacoby
21 months ago

  • Milestone changed from Awaiting Review to 2.7

Running bbPress 2.6 beta with WordPress 4.8 beta, I'm not seeing this.

Does replicating this require BuddyPress Groups? If so, can someone share the details of their setup to help us out?

#14 @lflier
13 months ago

For what it's worth, I just had exactly the same problem as the original poster: empty "topics started" and "replies created." I traced it to a custom WordPress taxonomy I had registered:

<?php
  register_taxonomy('author','post',array(
    'hierarchical' => false,
    'labels' => $labels,
    'show_ui' => true,
    'show_admin_column' => true,
    'update_count_callback' => '_update_post_term_count',
    'query_var' => true,
    'rewrite' => array( 'slug' => 'author' ),
  ));

The offending line was the first one, where I had registered the taxonomy as 'author'. Apparently this interfered with something in bbPress.

I solved the problem by registering the taxonomy as 'authors'. "Topics started" and "Replies created" now appear as they should.

Note: See TracTickets for help on using tickets.