Skip to:
Content

bbPress.org

Opened 5 years ago

Closed 5 years ago

#2686 closed defect (fixed)

wp 4.0 - bbpress bug when default permalinks set

Reported by: Robin W Owned by:
Milestone: Priority: highest
Severity: major Version:
Component: API - Rewrite Rules Keywords:
Cc:

Description

wp 3.9.2 + bbpress 2.5.4 + permalink settings default -> top level forums work, sub level forums work

wp 4.0 + bbpress 2.5.4 + permalink settings default –> top level forums work, sub level forums don’t work

wp 4.0 + bbpress 2.5.4 + permalink settings any other setting -> top level forums work, sub level forums do work

This is affecting several users on the support forums, so presumably lots more who aren't complaining !

Change History (4)

#1 @Robin W
5 years ago

Further info

for a forum structure where the parent is forum-a and the sub-forum is forum-b

under 4.0 the permalink is

http://www.mysite.com/?forum=forum-b

whereas to work it should be

http://www.mysite.com/?forum=forum-a/forum-b

#2 @netweb
5 years ago

  • Component changed from General to Rewrite Rules
  • Priority changed from high to highest
  • Severity changed from normal to major

Thanks Robin,

I've found the cause, it looks like WP:ticket#28611 WP:changeset:28803 is the culprit.

I haven't created a new ticket on WordPress Trac yet, there is a similar ticket WP:ticket:#29615 that may also be the same issue, I'm just awaiting feedback to confirm this. If it is the same issue we can track that ticket, if not I'll create a new ticket, either way it it is a WordPress Core regression and I'll push for a fix in WordPress 4.0.1.

Reverting the change in WP:changeset:28803 to /wp-includes/query.php resolves the issue.

Version 0, edited 5 years ago by netweb (next)

#3 @netweb
5 years ago

Ticket created upstream for WordPress 4.0.1 #WP29677, for any updates please check details of this ticket.

#4 @netweb
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to fixed
  • Status changed from new to closed

Upstream ticket is officially #WP29615 and will be released as part of WordPress 4.0.1

Closing this and marking as fixed in #WP29615

Note: See TracTickets for help on using tickets.