Skip to:
Content

bbPress.org

Opened 8 years ago

Closed 8 years ago

#2437 closed enhancement (worksforme)

Automatic Install/Upgrade bbPress Language Packs from GlotPress

Reported by: netweb Owned by: netweb
Milestone: Priority: normal
Severity: normal Version: trunk
Component: Locale - i18n/l10n Keywords:
Cc:

Description

Test and ensure support within bbPress plugin for WordPress Core #WP18200

Quoting dimadin:

http://core.trac.wordpress.org/ticket/18200#comment:28

  • On core/plugins/themes check for updates, we now check for languages too.
  • Checks for languages are done by searching for language files in WP_LANG_DIR, from which is then PO-Revision-Date taken to be sent to api.wp.org.
  • When any install/upgrade of core/plugin/theme is done, rechecks for updates are forced for everything so that there are fresh results against latest versions.
  • After that, upgrades for available languages updates for everything (core/plugins/themes) are forced.


Quoting nacin:

http://core.trac.wordpress.org/ticket/18200#comment:55
In [WP25059]:
Allow for plugin translations to be loaded from WP_LANG_DIR/plugins/$domain-$locale.mo.


Refer #WP18200 for extra changes, comments, context etc

Change History (4)

#1 @johnjamesjacoby
8 years ago

  • Milestone changed from Awaiting Review to 2.5

Thanks for the update. Moving to 2.5.

#2 @johnjamesjacoby
8 years ago

  • Milestone changed from 2.5 to 2.6

Should have been addressed in r5130.

Moving to 2.6 for testing, since it's not a regression. If it's working, go ahead and close this.

#3 @netweb
8 years ago

  • Owner set to netweb

#4 @netweb
8 years ago

  • Keywords needs-testing removed
  • Milestone 2.6 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Works for me

bbPress & BuddyPress will automatically receive translation updates (if enabled).

Translations will only be delivered if the translations have been copied/merged to:

This will be scripted and automated in the near future by @nacin and/or polyglots team.

Note: See TracTickets for help on using tickets.