Skip to:
Content

bbPress.org

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#2433 closed defect (fixed)

"Repair Forums" tools bug - Version 2.4

Reported by: fontadoni Owned by:
Milestone: Priority: high
Severity: critical Version:
Component: Tools Keywords:
Cc: stephen@…

Description

Main problem:

After running the repair forum tools, my forum currently looks empty, with no topics or posts. This is not a new forum installation, I have hundreds of posts and users.

Further details:

All forums, topics and replies have lost their “parent relationship” both on the user and admin ends. From inside Wordpress I can see forum names but they have 0 posts in them. I can see topic titles but they are not assigned to any parent Forum, have 0 replies and 0 voices (though data for author, date and freshness is still there) . Replies have “No Topic” and “No Forum” assigned to them, but the content is there. If I access each topic url, say by following the latest forum posts link, I can see each topic with their replies, though everything looks empty on the forums homepage (Oh bother! No topics were found here!).

This is what I did before all this happened:

  1. Upgraded wordpress to 3.6.1
  2. Ran all Repair Forum Tools at once

Other problems:

Previous to this issue, I had been having problems posting anything on my boards (either as admin or moderator). I would get “ERROR: Invalid author name submitted!”.

Attachments (5)

wp_posts.sql (3.2 KB) - added by fontadoni 7 years ago.
wp_postmeta.sql (929 bytes) - added by fontadoni 7 years ago.
wp_postmeta2.sql (926 bytes) - added by fontadoni 7 years ago.
wp-debug-bar.png (60.0 KB) - added by netweb 7 years ago.
mysql.png (19.1 KB) - added by fontadoni 7 years ago.

Download all attachments as: .zip

Change History (17)

#1 @netweb
7 years ago

  • Cc stephen@… added

I use the repair tools literally all the time as I constantly need them for the bbpress importers, maybe run them ~500 times in the past month and I'm yet to come across your issue once.

Reproducing your issue is not going to be easy.

Can you provide a link to your site and a specific topic that has a couple of replies.

#2 @johnjamesjacoby
7 years ago

  • Keywords reporter-feedback added
  • Milestone changed from Awaiting Review to 2.5

Was this a new bbPress installation, or did you convert from a previous forum (phpBB, vBulletin, bbPress 1.x, etc...)

#3 @fontadoni
7 years ago

Site: http://www.newdirt.org/forums/

Topic with replies: http://www.newdirt.org/forums/topic/capital-one-secured-card-graduating-to-unsecured/

I converted from bbPress 1.x to bbPress 2.2.4 about 7 months ago, no issues until now. Site is currently hosted at 1and1. This is not the first time I run the repair tools, though this happened right after using them. Not sure what happened.

#4 @netweb
7 years ago

Can you fire up phpMyAdmin on your host and run these three queries (they are based on your topic id 1935 and the 1st reply 2652 linked above), after each query hit the 'export' link at the bottom to export and save the results in SQL format then attach the .sql files to this ticket.

SELECT * FROM  `wp_posts` WHERE  `ID` = 1935
SELECT * FROM  `wp_postmeta` WHERE `post_id` = 1935
SELECT * FROM  `wp_postmeta` WHERE `post_id` = 2652

(If you are not using wp_ as your table prefix in your WordPress database change the queries above to match your WP database eg. myprefix_posts / myprefix_postmeta)

@fontadoni
7 years ago

@fontadoni
7 years ago

#5 follow-up: @fontadoni
7 years ago

Here are the attachments. The only thing I did was to delete the database name from each file.

Edit: Just for kicks, I tried registering a new user and I get "ERROR: Couldn’t register you… please contact the webmaster !" I still can't post anything either. As I said, I had this problem before. Don't know if it's related to my newest problem or not, but thought I should mention it.

Last edited 7 years ago by fontadoni (previous) (diff)

#6 @netweb
7 years ago

Thanks,

The data values in wp_posts is valid and looks fine. (SQL: Your topic ID 1935 and my topic ID 803)

INSERT INTO `wp_posts` VALUES 
(`ID`, `post_author`, `post_date`,           `post_date_gmt`,       `post_content`,    `post_title`,        `post_category`, `post_excerpt`, `post_status`, `comment_status`, `ping_status`, `post_password`, `post_name`,       `to_ping`, `pinged`, `post_modified`,        `post_modified_gmt`, `post_content_filtered`, `post_parent`, `guid`,            `menu_order`, `post_type`, `post_mime_type`, `comment_count`
(1935,             4, '2011-11-14 00:59:19', '2011-11-14 00:59:19', '<p>Hello, it...', 'Capital One Se...', 0,               '',              'publish',    'closed',         'closed',      '',              'capital-one-...', '',        '',        '2011-11-14 00:59:19', '2011-11-14 00:59:19', '',                     1882,         'http://www...',   0,            'topic',     '',                0);
(803,              1, '2013-09-24 02:27:31', '2013-09-24 02:27:31', 'bbP Topic Me...', 'bbP Topic Meta...', N/A              '',              'publish',    'closed',         'open',        '',              'bbp-topic-m...',  '',        '',        '2013-09-24 02:27:31', '2013-09-24 02:27:31', '',                     745,          'http://127...',   0,            'topic',     '',                0);

The data values in wp_postmeta, not so much.
(SQL: Your topic ID 1935 and reply ID 2652 & My topic ID 803 and reply ID 804)

INSERT INTO `wp_postmeta` VALUES (10494, 1935, '_bbp_author_ip', '98.195.160.125');
INSERT INTO `wp_postmeta` VALUES (10491, 1935, '_bbp_old_topic_id', '52');

INSERT INTO `wp_postmeta` VALUES (13889, 2652, '_bbp_author_ip', '173.233.107.144');
INSERT INTO `wp_postmeta` VALUES (13886, 2652, '_bbp_post_id', '315');

INSERT INTO `wp_postmeta` (`meta_id`, `post_id`, `meta_key`, `meta_value`) VALUES
(7047, 803, '_bbp_forum_id', '745'),
(7048, 803, '_bbp_topic_id', '803'),
(7049, 803, '_bbp_author_ip', '127.0.0.1'),
(7050, 803, '_bbp_last_reply_id', '804'),
(7051, 803, '_bbp_last_active_id', '804'),
(7052, 803, '_bbp_last_active_time', '2013-09-24 02:27:47'),
(7053, 803, '_bbp_reply_count', '1'),
(7054, 803, '_bbp_reply_count_hidden', '0'),
(7055, 803, '_bbp_voice_count', '1');

(7089, 804, '_bbp_forum_id', '745'),
(7090, 804, '_bbp_topic_id', '803'),
(7091, 804, '_bbp_author_ip', '127.0.0.1');

At a minimum each topic & reply in wp_postmeta should have _bbp_forum_id & _bbp_topic_id values assigned.

I see your MySQL database engine is MyISAM, I am using InnoDB but I know of no known issues here.

@netweb
7 years ago

#7 @netweb
7 years ago

To determine if the SQL query is being executed on your server you can do the following:

Can you install and activate the following WordPress plugins:
Debug Bar
Debug Bar Console
Debug Bar Extender

You will need to enable WP_DEBUG in your wp-config.php file and change it:
From: define('WP_DEBUG', false); To: define('WP_DEBUG', true);

Go to bbPress 'Repair Tools' and run the 'Recalculate the parent forum for each post' tool.
Click 'Debug' in the top right of your browser as per screen shot attached wp-debug-bar.png
Scroll down that query window and see if you can see the same details as I have in the screenshot for the repair tools query
eg. DELETE FROM wp_postmeta WHERE meta_key = '_bbp_forum_id';

#8 in reply to: ↑ 5 @netweb
7 years ago

Replying to fontadoni:

Edit: Just for kicks, I tried registering a new user and I get "ERROR: Couldn’t register you… please contact the webmaster !" I still can't post anything either. As I said, I had this problem before. Don't know if it's related to my newest problem or not, but thought I should mention it.

Just for kicks can you check the size limit of your MySQL database with your webhost!

Taking a stab that your database has reached its size limit and this is the cause of all your issues ;)

#9 @fontadoni
7 years ago

I just checked. Looks like the max database size on 1and1 is 100MB, and my database is currently at 115MB! You think this is the cause of all my issues? It sounds like it probably is. I haven't received any warnings or notices.

It looks like my database still has all tables from my old bbPress standalone board. Would you know how to delete them in order to bring my database size down? (I have attached a pic that shows tables with a bb_ prefix, are these from my old board?). I would like to get everything in working order before I attempt to move the site to another host.

@fontadoni
7 years ago

#10 @fontadoni
7 years ago

I went ahead and dropped the old bbpress tables, but this did not reduced the size of the database. Any ideas on how to reduce the size of the database now that I have deleted these tables?

#11 @fontadoni
7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

I was able to get the forums working again after changing my database's password and running the bbpress repair tools again. Stephen, I appreciate all your help. Thank you.

#12 @netweb
7 years ago

  • Keywords reporter-feedback removed
  • Milestone 2.5 deleted

Glad you got it sorted :)

Note: See TracTickets for help on using tickets.