Skip to:
Content

bbPress.org

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#2405 closed defect (fixed)

bbPress removes page title

Reported by: alexvorn2 Owned by: johnjamesjacoby
Milestone: 2.4.1 Priority: normal
Severity: normal Version: 2.3.2
Component: General Keywords: needs-patch
Cc:

Description

How to reproduce:

  1. create a new page
  2. activate the bbPress plugin ( trac version )
  3. visit the page

The title from "Page Title | Site Title" becomes "Site Titke"

Using multisite instalation.

Attachments (2)

2405.patch (6.5 KB) - added by johnjamesjacoby 6 years ago.
bbp_title() first pass fix
2405.2.patch (6.6 KB) - added by johnjamesjacoby 6 years ago.

Download all attachments as: .zip

Change History (13)

#1 @alexvorn2
6 years ago

using 2.3.2 version - works fine, but trac version does not!

#2 @alexvorn2
6 years ago

I think this is related to this #1764 ticket

#3 @alexvorn2
6 years ago

the problem is that the $title variable is recreated as an array, so the default value of the title is rewritten, http://wpimpact.com/wp-content/uploads/2013/09/title.png :)

Last edited 6 years ago by alexvorn2 (previous) (diff)

#4 @alexvorn2
6 years ago

  • Keywords needs-patch added

#5 follow-up: @johnjamesjacoby
6 years ago

  • Milestone changed from Awaiting Review to 2.5

Move importer tickets to 2.5 milestone for review and commit.

#6 in reply to: ↑ 5 @netweb
6 years ago

  • Milestone changed from 2.5 to Awaiting Review
  • Version changed from 2.1 to 2.3.2

Replying to johnjamesjacoby:

Move importer tickets to 2.5 milestone for review and commit.

This ticket has nothing to do with importers, removing 2.5 milestone.

@johnjamesjacoby
6 years ago

bbp_title() first pass fix

#8 @alex-ye
6 years ago

Nice work... It works fine with 2405.2.patch

#9 @alexvorn2
6 years ago

  • Milestone changed from Awaiting Review to 2.4.1

Moving to 2.4.1

#10 @johnjamesjacoby
6 years ago

  • Owner set to johnjamesjacoby
  • Resolution set to fixed
  • Status changed from new to closed

In 5101:

Tweak bbp_title() to better integrate with other plugins that filter 'wp_title'. Fixes #2405. (trunk)

#11 @johnjamesjacoby
6 years ago

In 5102:

Tweak bbp_title() to better integrate with other plugins that filter 'wp_title'. Fixes #2405. (2.4 branch)

Note: See TracTickets for help on using tickets.