Skip to:
Content

bbPress.org

Opened 7 years ago

Closed 7 years ago

#2369 closed defect (fixed)

New bbp_the_content() tinymce checker causes problems

Reported by: aaclayton Owned by: johnjamesjacoby
Milestone: 2.4 Priority: high
Severity: major Version: 2.3.2
Component: General Keywords:
Cc:

Description

I've been using TinyMCE with bbpress for some time, but the latest version broke my ability to invoke the editor using bbp_the_content() as intended by the plugin.

It is important for my site theme that I pass TinyMCE a custom editor stylesheet which I have always been able to do with the wp_editor function by passing the following argument:

'tinymce' => array(
	'content_css' 	=> APOC_URI . '/css/editor-content.css'
	),

As of bbpress 2.3.2, bbp_the_content looks for 'tinymce' === true, otherwise it runs esc_textarea() on the content before inserting it into the editor. This results in cases where TinyMCE IS being used, but bbp_the_content thinks it isn't, because it gets a tinymce array instead of simply a true/false.

Change History (2)

#1 @johnjamesjacoby
7 years ago

  • Milestone changed from Awaiting Review to 2.4

Confirmed. Fix imminent.

#2 @johnjamesjacoby
7 years ago

  • Owner set to johnjamesjacoby
  • Resolution set to fixed
  • Status changed from new to closed

In 5044:

Invert the explicit tinymce comparison in bbp_get_the_content() to look for !== false instead of === true. Fixes bug causing textarea output to be incorrectly escaped when using a custom tinymce stylesheet. Fixes #2369.

Note: See TracTickets for help on using tickets.