Skip to:
Content

bbPress.org

Opened 11 years ago

Closed 11 years ago

#2352 closed enhancement (duplicate)

Replies menu_order switch from wpdb->update to wp_update_post

Reported by: nofearinc's profile nofearinc Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.1
Component: Tools - Code Improvements Keywords: has-patch
Cc:

Description

Similarly to #2351, updating the last alive reference of $wpdb->update to wp_update_post for consistency in includes/replies/functions.php

Additionally, fixing a typo in a comment.

Attachments (1)

functions-menu-order.diff (670 bytes) - added by nofearinc 11 years ago.
wp_update_post migration and typo fix

Download all attachments as: .zip

Change History (3)

@nofearinc
11 years ago

wp_update_post migration and typo fix

#1 @johnjamesjacoby
11 years ago

Same comment as at #2351.

Can you explain what conditionals are being skipped, and what the bug is?

IIRC, the $wpdb->update() approach is used by design to avoid the additional overhead and potential for filter recursion caused by running through wp_update_post(), wp_insert_post(), et all.

#2 @johnjamesjacoby
11 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Going to close this as a duplicate of #2351, since they are attempting to solve the same issue in several places.

Note: See TracTickets for help on using tickets.