Skip to:
Content

Opened 4 years ago

Closed 4 years ago

#2279 closed defect (duplicate)

Private topics/replies showing up for visitors

Reported by: dhtc Owned by:
Milestone: 2.3 Priority: high
Severity: normal Version: 2.2.3
Component: API - Widgets Keywords: reporter-feedback
Cc: nashwan.doaqan@…, wordpress@…

Description

It was requested that a ticket be opened for this issue.

A number of users are seeing that private topics are visible to non-registered blog/forum users via the built in widgets.

Reference:
http://bbpress.org/forums/topic/private-forum-prevent-posts-from-showing-in-recent-topicscomments-widget

http://bbpress.org/forums/topic/bbpressbuddypress-private-replies-visible-to-non-logged-in-users/

Non-registered users can see the links in the widgets but get a 404 when attempting to access the link.

This bug is present in the latest official release as well as 2.3 RC1.

Change History (11)

#1 @alex-ye
4 years ago

  • Cc nashwan.doaqan@… added

What you mean exactly by "Private topics/replies" it could be have 2 meanings :

1 - topics/replies in private/hidden forums .
2 - Private topics/replies in public forums .

As I know bbPress still not support "Private topics/replies in public forums" perfectly , so it could be found some bugs in this case .

But if you talking about "topic/replies in private/hidden forums" it works very good , and I can't reproduce the bug you talked about .

#2 @netweb
4 years ago

I cannot reproduce this with either option

  • 1. Standard topics in a private or hidden forum do NOT show in bbPress 'recent topics widget '
  • 2. Private topics in a public forum do NOT show in 'bbPress topcs widget'

#3 @MZAWeb
4 years ago

  • Cc wordpress@… added

Can't replicate any of the two issues on those links (btw, they seem unrelated)

#4 @netweb
4 years ago

@dhtc I also removed your post in this thread as the two issues are unreleated and it might be confusing for others who come across similar issues.

#5 @alex-ye
4 years ago

@netweb , @MZAWeb , I know the bug can't reproduce in the two cases in widgets , and I can't think that some one will use bbPress in the case "2" now ..

Anyway private topics/replies in public forums can be broke in some certain cases , especially when you play around the bbPress users caps since the options still shows in the back-end interface .

Maybe the second case will be support if it really gets popular. as @johnjamesjacoby said
http://bbpress.trac.wordpress.org/ticket/2184

#6 follow-up: @johnjamesjacoby
4 years ago

  • Milestone changed from Awaiting Review to Future Release

Since no one can reproduce, moving to future release so we can rethink the visibility scope logic later.

#7 in reply to: ↑ 6 ; follow-up: @dhtc
4 years ago

Replying to johnjamesjacoby:

Since no one can reproduce, moving to future release so we can rethink the visibility scope logic later.

If you want to see the bug in action head on over to http://rrme.slmhc.on.ca.

The widgets near the footer show all forums posts to unlogged in users, whether they are public or prvate posts. Clicking on these links generates a 404 when you are not logged in.

PS Sorry about the delay. I never received email notification of replies.

#8 in reply to: ↑ 7 @netweb
4 years ago

  • Keywords reporter-feedback added

Replying to dhtc:

If you want to see the bug in action head on over to http://rrme.slmhc.on.ca.

Looking...

The widgets near the footer show all forums posts to unlogged in users, whether they are public or prvate posts. Clicking on these links generates a 404 when you are not logged in.

This is the list of 5 topics I see on your homepage for the bbPress Topics widget (The only bbPress widget you are using)

  • Recent Topics
  • Test Post 5
  • Test Post 4
  • Test Post 3
  • Test Post 2
  • Test Blog Post

The only one I can see is the last one in: 'Welcome › Forums › Public Forums › Public › Test Blog Post

I cannot see the first 4 and indeed they show a 404 'page not found'

We can 'see' that on your site but we still cannot reproduce the issue as we need to know exactly what each of your forums and topics privacy & visibilty settings are and what forums these topics are in.

Are the topics marked 'private or hidden' in the 'public' forum?

Are the topics set to default privacy and visibility but in a 'private' forum?

What other plugins are you using on your site? (might be a conflict with one of them)

We need as much detail as you can including what steps you took so we can reproduce the bug.

#9 follow-up: @johnjamesjacoby
4 years ago

This is probably more indicative of what's happening:

http://rrme.slmhc.on.ca/forums/users/preator/topics/

Can you disable all plugins other than bbPress, and report back if the issue still persists?

#10 in reply to: ↑ 9 ; follow-up: @alex-ye
4 years ago

Replying to johnjamesjacoby:

This is probably more indicative of what's happening:

http://rrme.slmhc.on.ca/forums/users/preator/topics/

Can you disable all plugins other than bbPress, and report back if the issue still persists?

After reading this comment , I think this related to #2284

#11 in reply to: ↑ 10 @johnjamesjacoby
4 years ago

  • Milestone changed from Future Release to 2.3
  • Resolution set to duplicate
  • Status changed from new to closed

Replying to alex-ye:

After reading this comment , I think this related to #2284

Confirmed. Putting into 2.3 milestone, and closing as a duplicate, since #2284 has a patch.

Note: See TracTickets for help on using tickets.