Skip to:
Content

bbPress.org

Opened 8 years ago

Closed 8 years ago

#2250 closed defect (fixed)

bbPress Widgets Bugs

Reported by: alex-ye Owned by:
Milestone: 2.3 Priority: normal
Severity: normal Version: 2.2.3
Component: API - Widgets Keywords: has-patch
Cc: nashwan.doaqan@…

Description

Hi , When I try to filter some bbPress widgets I found that they have many bugs !

All Widgets Bugs :
1 - Filter widget_title doesn't do anything .
2 - Hard to change the default widget settings .
3 - The empty widget control form should show the defaults .

Some widgets Bugs :
1 - Can't avoid printing before_title and after_title even if the title is empty !

BBP_Topics_Widget :
1 - Typo show_stickes instead of show_stickies in query args .
2 - Unnecessary use of bbp_exclude_forum_ids() function .
3 - Unnecessary convert post_status array to string .
4 - I found parent_forum functionality but no option for the user .

BBP_Replies_Widget :
1 - Unnecessary use of bbp_exclude_forum_ids() function .
2 - Unnecessary convert post_status array to string .

...etc

Attachments (1)

common-widgets.patch (39.1 KB) - added by alex-ye 8 years ago.

Download all attachments as: .zip

Change History (6)

#1 @alex-ye
8 years ago

  • Cc nashwan.doaqan@… added

#2 follow-up: @johnjamesjacoby
8 years ago

  • Milestone changed from Awaiting Review to 2.3

Thanks for the patch. It will need some cleaning up, but it's a good start. In the future, it's best to break these up into smaller tickets and patches, so we can address them individually.

Moving to 2.3

#3 in reply to: ↑ 2 @alex-ye
8 years ago

Replying to johnjamesjacoby:

Thanks for the patch. It will need some cleaning up, but it's a good start. In the future, it's best to break these up into smaller tickets and patches, so we can address them individually.

Moving to 2.3

Thanks :) , I will follow your advise in the future .

#4 @netweb
8 years ago

When testing this patch can we double check that any topics from Private or Hidden Forums do not show in the widget when the user does not posses the required Role / Capability.

(This was was recently reported on bbpress.org forums though I could not reproduce the issue.)

  • User not logged in.
  • User logged in with role 'Participant'
  • User logged in with role 'Moderator'
  • User logged in as 'Keymaster/SuperAdmin'

#5 @johnjamesjacoby
8 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [4806]) Audit up widget code:

  • Add missing UI for some options.
  • Introduce methods for parsing widget arguments.
  • General code clean up.
  • Props alex-ye.
  • Fixes #2250.
Note: See TracTickets for help on using tickets.