Skip to:
Content

bbPress.org

Opened 8 years ago

Closed 4 years ago

#2234 closed defect (fixed)

bbPress loses all post data on Submit when there was a validation error

Reported by: h646572 Owned by:
Milestone: 2.4 Priority: high
Severity: major Version: 2.2.3
Component: API - Anonymous Posting Keywords:
Cc:

Description

Steps to reproduce:

1) Turn on guest posting
2) Enter a valid name
3) Enter an invalid email.
4) Fill out some data in the post body.
5) Hit submit.

Actual results:

The name and email fields are filled out, but all of the post data is lost!

Expected results:

Post data is filled out so that the user doesn't lose their work.

Attachments (1)

Screen Shot 2013-02-28 at 7.13.50 PM.png (101.8 KB) - added by johnjamesjacoby 8 years ago.
Works for me?

Download all attachments as: .zip

Change History (15)

#1 @johnjamesjacoby
8 years ago

  • Milestone changed from Awaiting Review to Future Release

Moving to future release, pending some investigation.

#2 @netweb
8 years ago

  • Component changed from General to Anonymous Posting

Cannot reproduce....

Tried with various email formats eg test@test.test , test.test.test, test@

Form/Post data was always kept.

#3 follow-up: @h646572
8 years ago

Test forum here: http://www.learnopengles.com/forums/
Running bbPress 2.2.4

#4 in reply to: ↑ 3 @h646572
8 years ago

I noticed the attachment didn't have the visual editor enabled (it's enabled by default). Maybe it's related to that.

Last edited 8 years ago by h646572 (previous) (diff)

#5 @netweb
8 years ago

Name: netweb

Mail: test@test.test

Title: bbPress #2234

Clicked submit and post was accepted as valid: http://www.learnopengles.com/forums/topic/bbpress-2234/

Name: netweb

Mail: test@test

Title: bbPress #2234 #2

Clicked submit ERROR: Invalid email address submitted!

Confirmed: Post data was lost.

@h646572 Try disabling all your plugins except bbPress and switching to 2011/2012 WP themes.

#6 @h646572
8 years ago

Happens with all plugins (except bbPress) disabled. Happens with 2012 theme.

#7 @h646572
8 years ago

Also happens even if I disable the fancy editor. :(

#8 @netweb
8 years ago

Can you install /trunk and see if it still happens.

#9 @MZAWeb
8 years ago

  • Cc wordpress@… added

It's happening for me too, using trunk. Both in the new topic form as in the new reply form. Checking...

Last edited 8 years ago by MZAWeb (previous) (diff)

#10 @MZAWeb
8 years ago

  • Cc wordpress@… removed

bbpress/templates/default/bbpress/form-anonymous.php is using bbp_current_anonymous_user_data( 'email' ); to fill the value for those inputs. That functions ultimately gets the user information from a cookie. But the cookie doesn't get set in the first place, because of the validation error. Catch 22!

For those users that reported seeing this working, please try clearing cookies or using a different browser and try again?

Btw, that file I mention does this to set up those values:

value="<?php bbp_is_topic_edit() ? bbp_topic_author_email() : bbp_is_reply_edit() ? bbp_reply_author_email() : bbp_current_anonymous_user_data( 'email' ); ?>"

Hate those ? : chained. @JJJ, do you care if a re-do this in a less readable way?

#11 @netweb
8 years ago

Not entirely within the original scope of this ticket but....

Post data LOST when posting to BP Group Forum (WP r23646(/trunk) / bbP 2.2.4 / BP 1.6.4 (Group Forums Only))

Confirmed as User WP Role = Subscriber bbP Role = Participant

Confirmed as Admin WP Role = Administrator bbP Role = Keymaster

#12 @h646572
8 years ago

It did not appear for me with trunk, but it seems to be happening for others.

#13 @h646572
8 years ago

Once I go back to 2.2.4 I can confirm that the problem re-appears.

#14 @johnjamesjacoby
4 years ago

  • Milestone changed from Future Release to 2.4
  • Resolution set to fixed
  • Status changed from new to closed

This appears to be fixed in trunk.

Note: See TracTickets for help on using tickets.