Skip to:
Content

bbPress.org

Opened 9 years ago

Closed 9 years ago

#2229 closed defect (bug) (fixed)

Pass $is_edit to the topic and reply update actions

Reported by: alex-ye Owned by:
Milestone: 2.3 Priority: normal
Severity: normal Version: 2.1
Component: General - Administration Keywords: has-patch
Cc: nashwan.doaqan@…

Description

Hi , This is a small but important bug , when you edit a topic or reply from the back-end interface the active time , reply count ..etc is updated .

This cause a many problems in performance and logical structure , like an example the topic you edited form the wp-admin well be a new topic
with a fresh active time which well cause a wrong order in your forums pages like page-front-topics.php ..etc

I used $_POSTsave? to check if the topic or reply is edited or not , since WordPress 'save_post' hook doesn't pass the $update boolean var .

Attachments (2)

admin-replies.patch (793 bytes) - added by alex-ye 9 years ago.
admin-topics.patch (744 bytes) - added by alex-ye 9 years ago.

Download all attachments as: .zip

Change History (7)

#1 @alex-ye
9 years ago

  • Cc nashwan.doaqan@… added

#2 follow-up: @johnjamesjacoby
9 years ago

  • Milestone changed from Awaiting Review to 2.3

Confirmed. Thanks for the patches! Moving to 2.3.

#3 in reply to: ↑ 2 ; follow-up: @alex-ye
9 years ago

Replying to johnjamesjacoby:

Confirmed. Thanks for the patches! Moving to 2.3.

Great , but when it will be fixed in the trunk ?

#4 in reply to: ↑ 3 @alexvorn2
9 years ago

#2241 - duplicate

#5 @johnjamesjacoby
9 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [4786]) Merge topic/reply author with attributes metabox save action. Fixes bug causing freshness time to be incorrectly updated from within the dashboard. Props alex-ye. Fixes #2229.

Note: See TracTickets for help on using tickets.