Skip to:
Content

bbPress.org

Opened 7 years ago

Closed 7 years ago

#2178 closed defect (duplicate)

Pagination/Count is wrong when using shortcode [bbp-topic-index] and when stickies exist

Reported by: funnycat777 Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.2.3
Component: Component - Topics Keywords:
Cc:

Description

First of all, the display count "Viewing 17 topics - 1 through 15 (of 32 total)" does not make sense to me. (It's telling you that you're viewing 17 topics, but it is showing only 1 through 15 posts.) Second, pagination shows "1 2 3 →", but when I click on page 3, it does not contain any topics. If you go to page 2, it shows "Viewing 15 topics - 16 through 30 (of 30 total)", where it includes the super sticky and the sticky posts. Therefore, it looks like stickies are being counted twice, which is messing up the display count and pagination.

Attachments (3)

page1.png (49.7 KB) - added by funnycat777 7 years ago.
page2.png (44.5 KB) - added by funnycat777 7 years ago.
Page3.png (2.6 KB) - added by funnycat777 7 years ago.

Download all attachments as: .zip

Change History (5)

@funnycat777
7 years ago

@funnycat777
7 years ago

@funnycat777
7 years ago

#1 @johnjamesjacoby
7 years ago

  • Milestone Awaiting Review deleted

Thanks for the report and extra information. Closing as a duplicate of #1642.

#2 @gautamgupta
7 years ago

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.